ABEND 806-04



Get solution for your ABEND Codes & System Error Messages, SQL Codes, File Status etc...

ABEND 806-04

Postby CPANTX » Sat Mar 21, 2009 11:44 pm

When I run a compiled cobol program through run JCL, it gives abend 806-04, load module not found. When I went deeper, I got my problem which is described at http://www-01.ibm.com/support/docview.w ... sg1OA17662. How can I get around this problem?
CPANTX
 
Posts: 14
Joined: Sat Mar 21, 2009 11:23 pm
Has thanked: 0 time
Been thanked: 0 time

Re: ABEND 806-04

 

Re: ABEND 806-04

Postby CPANTX » Sat Mar 21, 2009 11:47 pm

CPANTX
 
Posts: 14
Joined: Sat Mar 21, 2009 11:23 pm
Has thanked: 0 time
Been thanked: 0 time

Re: ABEND 806-04

Postby CPANTX » Sun Mar 22, 2009 12:02 am

...continued from simulators and emulators.

I have given jcllib/steplib in my run JCL. The problems is occuring because of what is described in above link.
CPANTX
 
Posts: 14
Joined: Sat Mar 21, 2009 11:23 pm
Has thanked: 0 time
Been thanked: 0 time

Re: ABEND 806-04

Postby dick scherrer » Sun Mar 22, 2009 2:39 am

Hello and welcome to the forums,

The following is from your other post in the "free access" topic (those posts have been deleted).

The library where the program was linkedited is not in the joblib/steplib of the execute jcl or the module was not successfully complined/linked.

Check the compile output to ensure successful compile/link. Then check to make sure the loadlib is mentioned in the exec jcl.

If problems persist, contact the support people at the free site. They have all of the knowledge of their system.


If there are problems with compile/link/execution on that system, you need to ask the support people at the free site. We have no relationship with that system.
Hope this helps,
d.sch.
User avatar
dick scherrer
Global moderator
 
Posts: 6304
Joined: Sat Jun 09, 2007 8:58 am
Has thanked: 3 times
Been thanked: 91 times

Re: ABEND 806-04

Postby CPANTX » Sun Mar 22, 2009 11:05 pm

The above link also gives a zap to fix the problem. That zap removes new directory entry. How can that zap be used to fix this problem?
CPANTX
 
Posts: 14
Joined: Sat Mar 21, 2009 11:23 pm
Has thanked: 0 time
Been thanked: 0 time

Re: ABEND 806-04

Postby dick scherrer » Sun Mar 22, 2009 11:43 pm

Hello,

To repeat:
If problems persist, contact the support people at the free site. They have all of the knowledge of their system.

From the link:
The client's modules in question have aliases and were last linkedited with the S/360 Linkage Editor.
I suspect that your situation has nothing to do with a module last linked with the s/360 link editor or with an alias. . .

I suspect that your load library is incorrectly defined or there is a problem with the compile/link or execute jcl.

Nearly always some simple solution fixes these kinds problems - over 99% of the time it is a developer error, not something that requires a zap.
Hope this helps,
d.sch.
User avatar
dick scherrer
Global moderator
 
Posts: 6304
Joined: Sat Jun 09, 2007 8:58 am
Has thanked: 3 times
Been thanked: 91 times

Re: ABEND 806-04

Postby CPANTX » Mon May 18, 2009 9:02 pm

From the references:

Abend Code=806, Reason Code=04: program not found
problem: the requested program was not found in the specified library;
the message 'IEA703i 806-4 .. module accessed xxxx' states that
the program 'xxxx' was not found in the indicated library.

causes: 1) missing '//STEPLIB DD' or '//JOBLIB DD' statement for private
user library.
2) misspelled program name on '// EXEC PGM=name' statement for
private/public libraries.
3) program in public library has been deleted or renamed.

solution: 1) if you have programs stored in a private library, you must
tell the system via a 'STEPLIB' or 'JOBLIB' 'DD' statement where
to find the program; if either card is absent, the system will
search only its own system libraries for the requested program.
2) if 'JOBLIB' or 'STEPLIB' was present, check spelling of pro-
gram name on '// EXEC PGM=name' statement.
3) periodic upgrades of public programs are common;sometimes old
programs are deleted or replaced with newer versions; call the
Computer Center Help Desk at (312) 413-8080 for proper refer-
ence, replace program.


Now, again going into the problem:
1. I have given correct steplib.
2. I have spelt correct pgm name.
3. No question arises of problem with complie JCL as I have compiled the program by ISPF option 5.2.
4. Above #1 and #2 are relevent for RUN JCL.
5. Moreover, error msg is:
IEW4007I FIND FOR MODULE xxxxxxxx FAILED BECAUSE DIRECTORY
ENTRY IS NOT VALID FOR A LOAD MODULE.
It specifically states directory entry is invalid.

Obviously, error has to do with module last linkedited with S/360 Linkage Editor.
CPANTX
 
Posts: 14
Joined: Sat Mar 21, 2009 11:23 pm
Has thanked: 0 time
Been thanked: 0 time

Re: ABEND 806-04

Postby dick scherrer » Tue May 19, 2009 12:06 am

Hello,

Obviously, error has to do with module last linkedited with S/360 Linkage Editor.
Not obviously at all. . . It is doubtful that your code was linked with anything remotely involved with an s/360. . .

It is about 99% sure that you have some mistake in your use of components on the free site.

From the references:
. . .
call the
Computer Center Help Desk at (312) 413-8080 for proper refer-
ence, replace program.
Which reference?

As suggested previously, you may need to contact the free site support people.

If you receive a s806-04 and the problem module name is one you compiled/linked, you have made a mistake.
Hope this helps,
d.sch.
User avatar
dick scherrer
Global moderator
 
Posts: 6304
Joined: Sat Jun 09, 2007 8:58 am
Has thanked: 3 times
Been thanked: 91 times


Return to ABENDS & SQL Codes

 


  • Related topics
    Replies
    Views
    Last post