Omegamon XE on Z/OS.



Post anything related to mainframes (IBM & UNISYS) if not fit in any of the above categories

Omegamon XE on Z/OS.

Postby crazydoc » Wed Jan 20, 2016 5:59 pm

Good day. Please advise what to do if:
when i run Omegamon XE(5.1) received the message - "KCNCA003E - CF_ALLDATA FAILED IXCQUERY RC(0000000C), REASON(00000144)"
http://www-01.ibm.com/support/knowledgecenter/SSTFXA_6.2.0/com.ibm.itm.doc/sc23-7969-0031.htm?lang=en
The agent is configured for a single lpar on which CFRM is not used.
crazydoc
 
Posts: 44
Joined: Fri Jul 24, 2015 12:27 pm
Has thanked: 2 times
Been thanked: 0 time

Re: Omegamon XE on Z/OS.

 

Re: Omegamon XE on Z/OS.

Postby Robert Sample » Wed Jan 20, 2016 6:28 pm

Google is your friend. Googling kcnca003e returned 7 results, including a link to the Messages and Codes manual. That manual says this about the User Response to a KCNCA003E message:
Verify that the authorized OMEGAMON Subsystem is running and that the Coupling Facility Resource Management (CFRM) dataset is accessible from this LPAR. If the problem persists, call IBM Software Support for further assistance. If it is running and the problem persists, contact IBM Software Support for further assistance.
So if CFRM cannot be accessed from the LPAR, OMEGAMON XE cannot be used on it. The CF in CF_ALLDATA is referring to the Coupling Facility. If you think OMEGAMON XE should be running on that LPAR, contact your site support group for assistance.
Robert Sample
Global moderator
 
Posts: 3160
Joined: Sat Dec 19, 2009 8:32 pm
Location: East Dubuque, Illinois
Has thanked: 1 time
Been thanked: 190 times

Re: Omegamon XE on Z/OS.

Postby crazydoc » Wed Jan 20, 2016 6:51 pm

Robert Sample wrote:Google is your friend.

Added a link to the error description, I thought this would explain what I already used google...
So, Omegamon cannot be used without a Coupling Facility?
crazydoc
 
Posts: 44
Joined: Fri Jul 24, 2015 12:27 pm
Has thanked: 2 times
Been thanked: 0 time

Re: Omegamon XE on Z/OS.

Postby Robert Sample » Wed Jan 20, 2016 7:31 pm

So, Omegamon cannot be used without a Coupling Facility?
I have no idea. The place to ask that question is of the vendor -- IBM will be able to tell you what is needed for it to run.
Robert Sample
Global moderator
 
Posts: 3160
Joined: Sat Dec 19, 2009 8:32 pm
Location: East Dubuque, Illinois
Has thanked: 1 time
Been thanked: 190 times

Re: Omegamon XE on Z/OS.

Postby crazydoc » Thu Jan 21, 2016 4:35 pm

Robert Sample wrote:Coupling Facility Resource Management (CFRM) dataset is accessible from this LPAR.

Check the SYS1.XCF.CDS01(primary in issued "D XCF,COUPLE"). He has. Can anyone suggest methods to test its feasibility?
crazydoc
 
Posts: 44
Joined: Fri Jul 24, 2015 12:27 pm
Has thanked: 2 times
Been thanked: 0 time

Re: Omegamon XE on Z/OS.

Postby crazydoc » Fri Jan 22, 2016 12:47 pm

Tried to rebuild the CFRM dataset(SETXCF START,REBUILD - should fix some problems, to build a dataset if it is not), the result is:
IXC543I THE REQUESTED START,REALLOCATE WAS REJECTED: 736
COUPLE DATA SET FOR CFRM NOT AVAILABLE
I'm stumped and have no idea what to do. There is another feature in the agent settings - $DEFAULT enqplex(designed for single lpar) undecided(absent in the variant of choice, there was nothing).
Still hoping that someone can help here.

By the way, did you know that a patent for a Coupling Facility was approved in 1997? Randomly found on Google...=)
crazydoc
 
Posts: 44
Joined: Fri Jul 24, 2015 12:27 pm
Has thanked: 2 times
Been thanked: 0 time

Re: Omegamon XE on Z/OS.

Postby Robert Sample » Fri Jan 22, 2016 6:40 pm

You really, really, REALLY need to open a PMR with IBM on OMEGAMON XE configuration. I found this in the OMEGAMON XE for z/os Planning and Configuration Guide manual:
OMEGAMON XE on z/OS monitoring agents installed on monitored z/OS LPARs (logical partitions) provide comprehensive usage information for Sysplex-level resources such as coupling facilities, global enqueues, global resource serialization (GRS) ring systems, shared DASD groups, and cross-system coupling facilities (XCFs), as well as performance information for the service classes, report classes, and resource groups that use those resources.
But I also found
When you configure each monitoring agent, you have the option of defining its runtime environment as single LPAR environment or as a Sysplex environment. If you define it as a Sysplex environment, you must assign it to a defined Sysplex. Data from each runtime environment in a Sysplex is pooled at the primary Sysplex proxy (see Designating the Sysplex proxy).
So it sounds like a monitoring agent can be running on your LPAR. How to install and configure that monitoring agent will be in the manual -- so at a minimum you need to start on page 1 of the Planning and Configuration Guide manual and read until you can install the product on your LPAR or you determine that what you want to do is not possible. If the product is already installed, it may need to be removed and reinstalled.
Robert Sample
Global moderator
 
Posts: 3160
Joined: Sat Dec 19, 2009 8:32 pm
Location: East Dubuque, Illinois
Has thanked: 1 time
Been thanked: 190 times


Return to All other Mainframe Topics

 


  • Related topics
    Replies
    Views
    Last post
  • Omegamon and SAS
    by aeug » Fri Jun 10, 2011 11:39 am
    7 Replies
    2335 Views
    Last post by aeug View the latest post
    Thu Jun 23, 2011 12:40 pm