z/OS HTTP Server



Post anything related to mainframes (IBM & UNISYS) if not fit in any of the above categories

z/OS HTTP Server

Postby surferax » Mon Nov 03, 2008 8:34 am

Hi!
Im trying to make a simple HTTP Server on z/OS . I already set up the pass's and the
welcome page . But , when i open my web browser and try to access the web-page
i receive the error 403-Forbidden . It's very strange , because i have access to that file
when i am logged on the system...someone can help me ?

Thks,
User avatar
surferax
 
Posts: 7
Joined: Thu Sep 11, 2008 5:20 am
Has thanked: 0 time
Been thanked: 0 time

Re: z/OS HTTP Server

 

Re: z/OS HTTP Server

Postby dick scherrer » Mon Nov 03, 2008 8:52 am

Hello,

What id is presented by the web page when trying to connect? That id may have no permissions in the mainframe security system.
Hope this helps,
d.sch.
User avatar
dick scherrer
Global moderator
 
Posts: 6304
Joined: Sat Jun 09, 2007 8:58 am
Has thanked: 3 times
Been thanked: 91 times

Re: z/OS HTTP Server

Postby surferax » Mon Nov 03, 2008 10:58 pm

Hi dick scherrer,

No id is presented by the web page. It's too estrange because , per example , when i change the PASS statement below :

pass /* /my_private_folder/docs/*

to :

pass /* /etc/*

it works ! I mean , i can open the page specified in Welcome on my web browser.
But when I use " my /my_private_folder/docs/* it doesn't."
I Really don't know what is happening...

Thanks,

Regards,
User avatar
surferax
 
Posts: 7
Joined: Thu Sep 11, 2008 5:20 am
Has thanked: 0 time
Been thanked: 0 time

Re: z/OS HTTP Server

Postby dick scherrer » Mon Nov 03, 2008 11:13 pm

Hello,

Have you checked the permissions on the file system?

It sounds like you have the proper permissions in etc, but not the other?
Hope this helps,
d.sch.
User avatar
dick scherrer
Global moderator
 
Posts: 6304
Joined: Sat Jun 09, 2007 8:58 am
Has thanked: 3 times
Been thanked: 91 times

Re: z/OS HTTP Server

Postby surferax » Tue Nov 04, 2008 12:03 am

Hi!

You mean use "chmod" ?
I've already used "chmod 777 frtpage.html" , but it doesn't work...
Im getting crazy! :roll: :?
rs

Thanks,
User avatar
surferax
 
Posts: 7
Joined: Thu Sep 11, 2008 5:20 am
Has thanked: 0 time
Been thanked: 0 time

Re: z/OS HTTP Server

Postby dick scherrer » Tue Nov 04, 2008 1:07 am

Hello,

You may need to chmod the directories as well. . .

If you do a "long list" ((something like ls -afl ) iirc, been a while since i was a unix sysadmin), you can see the permissions for the directories and the files.
Hope this helps,
d.sch.
User avatar
dick scherrer
Global moderator
 
Posts: 6304
Joined: Sat Jun 09, 2007 8:58 am
Has thanked: 3 times
Been thanked: 91 times

Re: z/OS HTTP Server

Postby surferax » Tue Nov 04, 2008 1:07 am

Hi dick scherrer, problem solved !
The problem was in directory access permissions!

;)

Thanks,

Regards,
User avatar
surferax
 
Posts: 7
Joined: Thu Sep 11, 2008 5:20 am
Has thanked: 0 time
Been thanked: 0 time

Re: z/OS HTTP Server

Postby dick scherrer » Tue Nov 04, 2008 1:25 am

You're welcome - good luck :)

d
User avatar
dick scherrer
Global moderator
 
Posts: 6304
Joined: Sat Jun 09, 2007 8:58 am
Has thanked: 3 times
Been thanked: 91 times


Return to All other Mainframe Topics

 


  • Related topics
    Replies
    Views
    Last post