Batch Intertest Debugging



All other tools like QACenter, Strobe, Endevor, Telon, APAS, Scheduler, Auditor, DATA-XPERT, CoolGen, Intertest, AdvantageGen, COBTEST etc.

Batch Intertest Debugging

Postby Samir Mishra » Fri Sep 10, 2010 10:40 am

Hi,

Can any one please suggest to me the link where I can find the document which can teach me how to use the Intertest Batch facility???

I get a SOC13 when I try to enter the batch link facility after I select the program on which I have to apply the break-points... I think I am getting one of the steps wrong and thats the reason I'm getting the SOC13...

Help please..

Thanks & Regards,

Samir
Samir Mishra
 
Posts: 13
Joined: Fri Jul 30, 2010 1:37 pm
Has thanked: 0 time
Been thanked: 0 time

Re: Batch Intertest Debugging

 

Re: Batch Intertest Debugging

Postby Robert Sample » Fri Sep 10, 2010 2:37 pm

Intertest documentation would be available from the vendor -- contact them, or contact your site support group to find out where the documentation is kept. Most documentation is under copyright and cannot be posted in a public forum like this without breaking the law.

Furthermore, there is no such thing as S0C13 abend -- there are only three hexadecimal digits after the S (which stands for system). You may have gotten an S0C1, or an S013 -- but these are radically different abends. S0C1 is an operation error whereas S013 is a file open error.
Robert Sample
Global moderator
 
Posts: 3367
Joined: Sat Dec 19, 2009 8:32 pm
Location: East Dubuque, Illinois
Has thanked: 1 time
Been thanked: 222 times

Re: Batch Intertest Debugging

Postby Samir Mishra » Mon Sep 13, 2010 5:32 pm

Hi,

Thanks for answering... neways I got rid of the OC13C error code I was getting. But now I have a problem with the JCL created by Batch Intertest in which it inserts a program CAMRBL01to run and is specified in the SYSTSIN with the PARM 'NN'.

Following is the error message thats received:

READY
DSN SYSTEM(TEST)
DSN
RUN PROGRAM(CAMRBL01) PARM('NN') PLAN(PTNRB01)
IKJ56641I DSN ENDED DUE TO ERROR+
IKJ56641I SYSTEM ABEND CODE 0C1 REASON CODE 00000001


JOB: ABCDEFG STEP: STEP0001 PROGRAM: INTDSOCE
****************************
* * S-0C1 *
* A B E N D *------------*
* * INTDSOCE *
****************************

CAPD112W SYMBOLIC INFORMATION NOT FOUND FOR PROGRAM "INTDSOCE".


INVALID INSTRUCTION

INTERRUPT OCCURRED AT ADDRESS 0007ABBE AT OFFSET +000066 IN PROGRAM INTDSOCE
LAST KNOWN I/O OR CALL OCCURRED AT ADDRESS 0007ACA4 AT OFFSET +00014C IN PROGRAM
THE Z/OS BREAKING EVENT ADDRESS IS 00000000 0007ACA8 AT OFFSET +000150 IN PROGRA

I am unable to figure out the program that has abended: is it INTDSOCE or CAMRBL01 or is it some other error???

Kindly help... :roll:

Thanks & Regards,

Samir
Samir Mishra
 
Posts: 13
Joined: Fri Jul 30, 2010 1:37 pm
Has thanked: 0 time
Been thanked: 0 time

Re: Batch Intertest Debugging

Postby Robert Sample » Mon Sep 13, 2010 6:53 pm

neways I got rid of the OC13C error code I was getting.
No, you did not -- there is no such error on a z/OS machine. When you are not competent to enter three (and only three) characters 0-9 or A-F, this brings into question everything you post. Since the error code specifically states the program that abended, why are you questioning that? The system does not lie to you -- if it says program INTDSOCE had an abend, then that program had an abend. Since it appears to be one of the vendor's programs, your only realistic option to resolve the problem is to contact the vendor and open a problem report giving the exact error messages you received.
Robert Sample
Global moderator
 
Posts: 3367
Joined: Sat Dec 19, 2009 8:32 pm
Location: East Dubuque, Illinois
Has thanked: 1 time
Been thanked: 222 times

Re: Batch Intertest Debugging

Postby dick scherrer » Mon Sep 13, 2010 11:54 pm

Hello,

Suggest you work with your dba or some senior on your project to resolve the problem with this.

When you "got rid of" the s013, it was not a fix - it just replaced that problem with another. . .
Hope this helps,
d.sch.
User avatar
dick scherrer
Global moderator
 
Posts: 6304
Joined: Sat Jun 09, 2007 8:58 am
Has thanked: 3 times
Been thanked: 91 times

Re: Batch Intertest Debugging

Postby Samir Mishra » Tue Sep 14, 2010 10:19 am

Hi,

I think I know whom to approach at what position... Batch intertest is something thats my initiative for my team and am not able to get thru bcpz of the error... just wanted to know that could the stated problem be a load issue?

thanks
Samir Mishra
 
Posts: 13
Joined: Fri Jul 30, 2010 1:37 pm
Has thanked: 0 time
Been thanked: 0 time

Re: Batch Intertest Debugging

Postby dick scherrer » Tue Sep 14, 2010 10:27 am

Hello,

just wanted to know that could the stated problem be a load issue
I don't understand what this is asking. All abends are associated with some load module. . .

Suggest you open an issue with CA Support. They also have all of the documentation. If your organization is licensed to use the product, all of the material may be downloaded free.
Hope this helps,
d.sch.
User avatar
dick scherrer
Global moderator
 
Posts: 6304
Joined: Sat Jun 09, 2007 8:58 am
Has thanked: 3 times
Been thanked: 91 times


Return to All Other Tools

 


  • Related topics
    Replies
    Views
    Last post