Cics webservices



Support for CICS/ESA, CICS/TS & Transaction Gateway, CICS Configuration Manager and CICS Performance Analyzer

Cics webservices

Postby Bjoern » Tue Dec 04, 2007 5:57 pm

Hi,
I have installed a pipeline in cics successful. After that I verify the issue with
CEMT INQUIRE WEBSERVICE


The return is
Webs(GetSquare1                      ) Pip(WSPIPE01)
   Unu                                             


The normal return for a webservice is
Webs(inquireSingle83                 ) Pip(PIPE83  )   
   Ins Uri($452100 ) Pro(DFH0XCMN) Com                       Dat(20060810)


Where I get more information about my webservice GetSquare1 in cics?

Regards
Björn
Bjoern
 
Posts: 27
Joined: Mon Oct 08, 2007 7:16 pm
Has thanked: 0 time
Been thanked: 0 time

Re: Cics webservices

 

Re: Cics webservices

Postby Bjoern » Wed Dec 05, 2007 4:41 pm

Hi,
in the meantime I have more informations, but no answer to my problem.

Normally, CICS should after a
CEDA INSTALL PIPELINE(WSPIPE01) GROUP(SIMPLWS1)

automatically configure and install the URIMAP and WEBSERVICE Ressources. I can test this with the command
CEMT INQUIRE WEBSERVICE


In this list my webservice is not represented. After a
CEMT PERFORM PIPELINE(WSPIPE01) SCAN

I have the following entry
Webs(GetSquare1                      ) Pip(WSPIPE01)
   Unu

Unu stands for unusable.

I have installed a URIMAP and WEBSERVICE ressources in my group and then I have installed the pipeline again. The result is the same.

I hope anybody can help me.

Regards
Björn
Bjoern
 
Posts: 27
Joined: Mon Oct 08, 2007 7:16 pm
Has thanked: 0 time
Been thanked: 0 time

Re: Cics webservices

Postby Bjoern » Wed Dec 05, 2007 5:02 pm

Hi,
I have an additional question. The tutorial says that I shall use RDO to define the ressources manually. I have searched for that, but I get only things like this
DEFNE PROFILE(ARSPNOUC) GROUP(ODSAPI)                     
DESCRIPTION(ONDEMAND PROFILE)
UCTRAN(NO)


Regards
Björn
Bjoern
 
Posts: 27
Joined: Mon Oct 08, 2007 7:16 pm
Has thanked: 0 time
Been thanked: 0 time

Re: Cics webservices

Postby Bjoern » Wed Dec 05, 2007 11:33 pm

Hi,
ok it works fine. The answer was that the shelf directory has to be writable.

Regards
Björn
Bjoern
 
Posts: 27
Joined: Mon Oct 08, 2007 7:16 pm
Has thanked: 0 time
Been thanked: 0 time

Re: Cics webservices

Postby dick scherrer » Thu Dec 06, 2007 2:38 am

Hello Bjorn,

Thank you for posting your progress :)

d
User avatar
dick scherrer
Global moderator
 
Posts: 6308
Joined: Sat Jun 09, 2007 8:58 am
Has thanked: 3 times
Been thanked: 90 times

Re: Cics webservices

Postby Bjoern » Fri Dec 07, 2007 7:35 pm

Hi,
I have the following problem. When I access the webservice I get a fault message "programm is not linkable". What can I do?

I have compiled my cobol program with the following jcl script
000100 //USERID2C JOB (),CLASS=A,MSGCLASS=M,MSGLEVEL=(1,1),NOTIFY=&SYSUID,
000200 //         REGION=4M
000300 //STEP1    EXEC COBCICS,PARM.TRN='COBOL3'
000400 //TRN.SYSIN DD DSN=&SYSUID..CICS.COB(SQUARE1),DISP=SHR
000500 //LKED.SYSLMOD DD DSN=&SYSUID..CICS.LOAD,DISP=SHR
000600 //LKED.SYSIN DD *
000700  NAME SQUARE1(R)
000800 /*

I get the message that MAXCC=12. Well, I thought that now the system has to create a member SQUARE1 in the dataset USERID2.CICS.LOAD. But there is no dataset. The next problem is, that the JES job statistic says that:
INDEX='CICSTS23.CICS', Qualifier(s) for CICS libraries

I thought the right INDEX is 'CICSTS31.CICS'.

I hope anybody has an idea for me.

Regards
Björn
Bjoern
 
Posts: 27
Joined: Mon Oct 08, 2007 7:16 pm
Has thanked: 0 time
Been thanked: 0 time

Re: Cics webservices

Postby dick scherrer » Fri Dec 07, 2007 9:23 pm

Hello,

I'd suggest you talk with your system support people or your CICS system programmer(s).

The problem you are dealing with is site-specific and the people familiar with your environment will best able to help.

One thing you might do before talking with them is to know why you are getting the 12. There will be diagnostic info in the compile/link output.
Hope this helps,
d.sch.
User avatar
dick scherrer
Global moderator
 
Posts: 6308
Joined: Sat Jun 09, 2007 8:58 am
Has thanked: 3 times
Been thanked: 90 times

Re: Cics webservices

Postby Bjoern » Mon Dec 10, 2007 10:09 pm

Hallo,
ok I have found the problem. In the Dataset USERID2.LIB is no member SQUARE1. I have used the following jcl script.
000100 //USERID2C JOB (),CLASS=A,MSGCLASS=M,MSGLEVEL=(1,1),NOTIFY=&SYSUID,
000200 //         REGION=4M
000300 //STEP1    EXEC COBCICS,PARM.TRN='COBOL3'
000400 //TRN.SYSIN DD DSN=&SYSUID..CICS.COB(SQUARE1),DISP=SHR
000500 //LKED.SYSLMOD DD DSN=&SYSUID..LIB,DISP=SHR
000600 //LKED.SYSIN DD *
000700  NAME SQUARE1(R)
000800 /*


In the JES job statistic I have found the line
IEF202I USERID2C LKED STEP1 - STEP WAS NOT RUN BECAUSE OF CONDITION CODES


Here is more from this job statistic
...
IGD101I SMS ALLOCATED TO DDNAME (SYSUT7  )                                   
        DSN (SYS07344.T182303.RA000.USERID2C.R0106304    )                   
        STORCLAS (PRIM90) MGMTCLAS (        ) DATACLAS (        )             
        VOL SER NOS= SMS003                                                   
IEF142I USERID2C COB STEP1 - STEP WAS EXECUTED - COND CODE 0012               
IEF285I   IGY330.SIGYCOMP                              KEPT                   
IEF285I   VOL SER NOS= Z5RES2.                                               
IEF285I   CICSTS23.CICS.SDFHCOB                        KEPT                   
IEF285I   VOL SER NOS= Z5CIC1.                                               
IEF285I   CICSTS23.CICS.SDFHCOB                        KEPT                   
IEF285I   VOL SER NOS= Z5CIC1.                                               
IEF285I   CICSTS23.CICS.SDFHMAC                        KEPT                   
IEF285I   VOL SER NOS= Z5CIC1.                                               
IEF285I   CICSTS23.CICS.SDFHSAMP                       KEPT                   
IEF285I   VOL SER NOS= Z5CIC1.                                               
IEF285I   USERID2.USERID2C.JOB04039.D0000103.?         SYSOUT                 
IGD105I SYS07344.T182303.RA000.USERID2C.SYSCIN.H01   DELETED,   DDNAME=SYSIN 
IGD106I SYS07344.T182303.RA000.USERID2C.LOADSET.H01  PASSED,    DDNAME=SYSLIN
IGD105I SYS07344.T182303.RA000.USERID2C.R0106298     DELETED,   DDNAME=SYSUT1
IGD105I SYS07344.T182303.RA000.USERID2C.R0106299     DELETED,   DDNAME=SYSUT2
IGD105I SYS07344.T182303.RA000.USERID2C.R0106300     DELETED,   DDNAME=SYSUT3
IGD105I SYS07344.T182303.RA000.USERID2C.R0106301     DELETED,   DDNAME=SYSUT4
IGD105I SYS07344.T182303.RA000.USERID2C.R0106302     DELETED,   DDNAME=SYSUT5
IGD105I SYS07344.T182303.RA000.USERID2C.R0106303     DELETED,   DDNAME=SYSUT6
IGD105I SYS07344.T182303.RA000.USERID2C.R0106304     DELETED,   DDNAME=SYSUT7
IEF373I STEP/COB     /START 2007344.1823                                     
IEF374I STEP/COB     /STOP  2007344.1823 CPU    0MIN 00.05SEC SRB    0MIN 00.00
IEF202I USERID2C COPYLINK STEP1 - STEP WAS NOT RUN BECAUSE OF CONDITION CODES 
IEF272I USERID2C COPYLINK STEP1 - STEP WAS NOT EXECUTED.                       
IEF373I STEP/COPYLINK/START 2007344.1823                                       
IEF374I STEP/COPYLINK/STOP  2007344.1823 CPU    0MIN 00.00SEC SRB    0MIN 00.00
IEF202I USERID2C LKED STEP1 - STEP WAS NOT RUN BECAUSE OF CONDITION CODES     
IEF272I USERID2C LKED STEP1 - STEP WAS NOT EXECUTED.                           
IEF373I STEP/LKED    /START 2007344.1823                                       
IEF374I STEP/LKED    /STOP  2007344.1823 CPU    0MIN 00.00SEC SRB    0MIN 00.00
IEF237I 5430 ALLOCATED TO SYS00001                                             
IEF285I   SYS07344.T182304.RA000.USERID2C.R0106306     KEPT                   
IEF285I   VOL SER NOS= SMS002.                                                 
IGD105I SYS07344.T182303.RA000.USERID2C.LOADSET.H01  DELETED,   DDNAME=SYSLIN 
IEF375I  JOB/USERID2C/START 2007344.1823                                       
IEF376I  JOB/USERID2C/STOP  2007344.1823 CPU    0MIN 00.07SEC SRB    0MIN 00.00
******************************* Bottom of Data ********************************


Thanks for help.

Regards
Björn
Bjoern
 
Posts: 27
Joined: Mon Oct 08, 2007 7:16 pm
Has thanked: 0 time
Been thanked: 0 time

Re: Cics webservices

Postby dick scherrer » Tue Dec 11, 2007 7:52 am

Hello,

Your post shows that the linkage editor step was not run - probably due to some prior error(s).
Hope this helps,
d.sch.
User avatar
dick scherrer
Global moderator
 
Posts: 6308
Joined: Sat Jun 09, 2007 8:58 am
Has thanked: 3 times
Been thanked: 90 times

Re: Cics webservices

Postby lee dawn » Tue Dec 11, 2007 10:14 am

condition code 12, did you check for cobol compile errors ?
lee dawn
 
Posts: 7
Joined: Fri Nov 02, 2007 9:45 pm
Has thanked: 0 time
Been thanked: 0 time

Next

Return to CICS

 


  • Related topics
    Replies
    Views
    Last post