Unable to move and get correct data on CICS screen



Support for CICS/ESA, CICS/TS & Transaction Gateway, CICS Configuration Manager and CICS Performance Analyzer

Unable to move and get correct data on CICS screen

Postby jatin_compsci » Thu Mar 27, 2014 11:52 am

Hi,

I am stucked on one of my CICS screen, it was supposed to go to next screen after i press enter but unfortunately it is not going to next screen and moreover it is showing Junk data as value of some of the fields.

I have copied the production load of the same CICS program(responsible for that screen) to test region but it is still not wokring,the binding has also been done correctly without errors.

In prod region the same screen is working fine and going to next screen, but in Test it gets stucked and is not moving to next screen.

No code changes has been perofrmed, since i am using production load i assume it should work correctly.

Sorry as due to client data protection i cant share the screens.
But any help or suggestions for me is highly appreciated.

Many thanks in advance.

Regards,
Jatin
jatin_compsci
 
Posts: 17
Joined: Wed Feb 13, 2013 1:30 pm
Has thanked: 1 time
Been thanked: 0 time

Re: Unable to move and get correct data on CICS screen

 

Re: Unable to move and get correct data on CICS screen

Postby dick scherrer » Thu Mar 27, 2014 6:44 pm

Hello,

but in Test it gets stucked and is not moving to next screen.
What causes the process to move to the next screen?

Sorry as due to client data protection i cant share the screens.
Why can you not show the actual screens without the data that needs to be protected?
Hope this helps,
d.sch.
User avatar
dick scherrer
Global moderator
 
Posts: 6308
Joined: Sat Jun 09, 2007 8:58 am
Has thanked: 3 times
Been thanked: 90 times

Re: Unable to move and get correct data on CICS screen

Postby Robert Sample » Thu Mar 27, 2014 6:48 pm

You will probably need to contact your site support group and your CICS support specifically. The issue most likely is something in the CICS region setup that is different between production and test -- and those setup issues are NOT something you can change yourself.
Robert Sample
Global moderator
 
Posts: 3123
Joined: Sat Dec 19, 2009 8:32 pm
Location: Bellevue, Iowa
Has thanked: 1 time
Been thanked: 182 times

Re: Unable to move and get correct data on CICS screen

Postby jatin_compsci » Thu Mar 27, 2014 10:49 pm

Hi Dick/Robert,

Thanks a lot :) , it was the issue of region setup only. I regenerated APS cobol module in test, compiled and binded it again to DBRMLIB.
It worked then!

@Dick The process which allowed the screen to move to next screen is data should be there in sort-code and customer number field and then pressing Enter.
Previously values were not getting populated, now values came.And as its a banking client we are not supposed to show screens without data too, i know it is suggested as per forum rules but cant help though :(

Thanks and Regards,
Jatin Shrivastava
jatin_compsci
 
Posts: 17
Joined: Wed Feb 13, 2013 1:30 pm
Has thanked: 1 time
Been thanked: 0 time


Return to CICS

 


  • Related topics
    Replies
    Views
    Last post