A strange problem!



IBM's flagship sort product DFSORT for sorting, merging, copying, data manipulation and reporting. Includes ICETOOL and ICEGENER

A strange problem!

Postby j2422tw » Mon Nov 10, 2008 3:44 pm

I have an portion of VB SMF input data:

    En    XXXXJES2             O                                     
D107C90030EEEEDCEF00000B0200000D0B000000000000000000000000000008000000
EE0655181F77771522010000060100060801000000000000000000000000001E0F0100
----------------------------------------------------------------------
   '      XXXXJES2             O               O         m           
D107210030EEEEDCEF00000B0200000D0B0000080400000D0000000D09000000000000
EE0D9D181F77771522040000060100060801001E080100160801001E04010000000000
----------------------------------------------------------------------
   '      XXXXDEEAKI1   E     TWSC       En       ,   ADRDSSU DMPVSAM
1007210030EEEECCCCDCF407C00030EEEC4444007C900300006000CCDCEEE4CDDEECD4
E40D9E181F7777455129100659181F3623000010655181F000B0001494224044752140
----------------------------------------------------------------------
   '      XXXXJES2             O               O         m           
D107210030EEEEDCEF00000B0200000D0B0000080400000D0000000D0900000D000000
EE0D9E181F77771522050000060100060801001E080100160801001E0401003C0F0100
----------------------------------------------------------------------
   '      XXXXDEEAKI1   E     TWSC       En       ,   ADRDSSU DMPVSAM
1007210030EEEECCCCDCF407C00030EEEC4444007C900300006000CCDCEEE4CDDEECD4
E40D9E181F7777455129100659181F3623000010655181F000B0001494224044752140
----------------------------------------------------------------------
   '      XXXXDEEAKI1   E     TWSC       En       ,     E$         \ 
1007210030EEEECCCCDCF407C00030EEEC4444007C90030000600007C5003000033E00
E50D9E181F7777455129100659181F3623000010655181F000B000065B181F000E8000


There are 6 records, the 6th character of first record is SMF type : X'1E', X'04', or X'05'

When I run the SORT to include the type 04, and type 05, the record count is 3, output is correct.

The sort1 statement:

   SORT FIELDS=COPY                                             
    INCLUDE COND=((6,1,BI,EQ,X'04',OR,6,1,BI,EQ,X'05'),OR,     
                  19,7,CH,EQ,C'DEEAKI1')                       
   OPTION VLSHRT                                               


But when I run another SORT to include the type 04, 05, and type 30 (1E), the count is 5

The sort2 statement:

  SORT FIELDS=COPY                                                 
  INCLUDE COND=(((6,1,BI,EQ,X'04',OR,6,1,BI,EQ,X'05'),AND,         
               19,7,CH,EQ,C'DEEAKI1'),OR,                         
               (6,1,BI,EQ,X'1E',AND,                             
              215,7,CH,EQ,C'DEEAKI1'))                           
  OPTION VLSHRT                                                     


I find the 6th record, type 05 , is missing.

I don't know which statement or step is wrong.

Thanks & regards,

Jerry
j2422tw
 
Posts: 25
Joined: Wed Sep 19, 2007 9:46 am
Has thanked: 0 time
Been thanked: 0 time

Re: A strange problem!

 

Re: A strange problem!

Postby Frank Yaeger » Mon Nov 10, 2008 10:04 pm

You should use OPTION VLSCMP rather than OPTION VLSHRT.

For a discussion of the difference, see the "How can I use INCLUDE/OMIT with "short" fields?" Ask Professor Sort item at:

http://www.ibm.com/systems/support/stor ... ssor_sort/

But you will still only get the type 30 record if the conditions are satisfied which I suspect they're not. Either you don't have the constant in the record, you specified its position incorrectly (did you add 4 for the RDW?), or the record is "short".
Frank Yaeger - DFSORT Development Team (IBM) - yaeger@us.ibm.com
Specialties: JOINKEYS, FINDREP, WHEN=GROUP, ICETOOL, Symbols, Migration
=> DFSORT/MVS is on the Web at http://www.ibm.com/storage/dfsort
User avatar
Frank Yaeger
Global moderator
 
Posts: 1080
Joined: Sat Jun 09, 2007 8:44 pm
Has thanked: 0 time
Been thanked: 14 times

Re: A strange problem!

Postby j2422tw » Tue Nov 11, 2008 8:57 am

Dear Frank:

I had test the VLSCMP, yes, that's the reason of record missing.

The 6 records I posted is all satisified, because using File-Aid to display and cut/paste
to web page, so the RDW is not appear.

Thanks Frank, I know I can get the answer if post in here ;)

Jerry
j2422tw
 
Posts: 25
Joined: Wed Sep 19, 2007 9:46 am
Has thanked: 0 time
Been thanked: 0 time


Return to DFSORT/ICETOOL/ICEGENER

 


  • Related topics
    Replies
    Views
    Last post