Compilation Error EDC4015



IBM's cross-platform compiler PL/I for MVS, VM & VSE, OS/390 and Enterprise PL/I for z/OS

Compilation Error EDC4015

Postby surime72 » Fri May 11, 2012 2:21 pm

hi
i was trying to compile pli prog it was showing error as
DATA SET 'SYS1.SCSPLOAD' NOT IN CATALOG

DSNH740I ======= PLI FINISHED, RC = 4 ======= LISTING IN TEMP.LIST ===========
=================
DSNH740I ======= PRELINK FINISHED, RC = 4 ======= LISTING IN TEMP.SYSOUT.PRELL

WARNING EDC4015: Unresolved references are deteced:ted:
INFORMATIONAL EDC4013: No map displayed as no writable static was found.
surime72
 
Posts: 107
Joined: Sun Oct 23, 2011 1:45 pm
Has thanked: 0 time
Been thanked: 0 time

Re: Compilation Error EDC4015

 

Re: compilation error

Postby enrico-sorichetti » Fri May 11, 2012 3:02 pm

DATA SET 'SYS1.SCSPLOAD' NOT IN CATALOG

what is that You do not understand in the message
a dataset referenced in Your compilation procedure was not found AMEN

nobody on the forum belongs to Your organization,
so.... nobody knows about Your installation naming standards
products installed and ... ... ...

the best and only place to ask is Your support
whose job is also to provide properly tested compilation procedures.

the messages are warning and information
check to see if something has/can be done to get rid of them
Last edited by enrico-sorichetti on Fri May 11, 2012 3:07 pm, edited 2 times in total.
cheers
enrico
When I tell somebody to RTFM or STFW I usually have the page open in another tab/window of my browser,
so that I am sure that the information requested can be reached with a very small effort
enrico-sorichetti
Global moderator
 
Posts: 2790
Joined: Fri Apr 18, 2008 11:25 pm
Has thanked: 0 time
Been thanked: 148 times

Re: compilation error

Postby surime72 » Fri May 11, 2012 5:03 pm

hi
we are not using jcl as a compilation.i was new for the comiplation of this way so iwas facing error as IEW2735S DA0F OUTPUT DATA SET FOR DDNAME SYS00244 HAS INVALID RECORD FORMAT.
RECFM=U IS REQUIRED.
DSNH740I ======= LINK FINISHED, RC = 12 ======= LISTING IN TEMP.LINKLIST =====
=======================
DSNH759I DSNH TERMINATING, LINK RC = 12
surime72
 
Posts: 107
Joined: Sun Oct 23, 2011 1:45 pm
Has thanked: 0 time
Been thanked: 0 time

Re: compilation error

Postby Robert Sample » Fri May 11, 2012 5:09 pm

Even though you are not using JCL for a compile, you still MUST talk to someone AT YOUR SITE about the error messages you are receving. Nobody on this forum can possibly help you, since each site can cusotmize compile procedures (both TSO and batch) and there is no way anybody not working at your site could possibly know how your site customized things.
Robert Sample
Global moderator
 
Posts: 3535
Joined: Sat Dec 19, 2009 8:32 pm
Location: Dubuque, Iowa, USA
Has thanked: 1 time
Been thanked: 252 times


Return to PL/I

 


  • Related topics
    Replies
    Views
    Last post