Job Dependency Lead Time Not Satisfied



Unicenter CA-7 Job Management: CA's workload automation tool for managing, visualizing, automating, optimizing applications

Job Dependency Lead Time Not Satisfied

Postby rickaroo99 » Sat Jul 18, 2009 5:16 pm

I have dependent job 'B' which has a predecessor 'A' 'with a lead time of 14 for SCHID=2. The predecessor job triggers in and always completes well within 14 hours. Two times a month this dependency doesn't get satisfied. Job 'A' scanned in at 3 AM this morning and predecessor job 'B' ran from 9:30 PM to 10:07 PM last night. On these two nights, I am running special cycles that I don't believe should cause conflicts.

Dependent job runs multiple times a day with different SCHIDs, but only once per day as SCHID=2. Dependent job also has multiple other predecessors for SCHID=2 that get satisfied all the time.

Here is the final wrinkle to this puzzle. Predecessor job 'B' literally runs 365 days a year while dependent job 'A' only runs on business days. I don't believe this would pose a problem though as I believe there are similar days throughout the month when dependent job 'A' would trigger in after midnight and still shave the dependency satisfied.

I am a consultant on a project and as such have limited access to CA/7. Most of my knowledge is gleaned from LJOB commands and such. I do not have access to the actual job screens. My support contacts are of no help here. Perhaps I could live with a LT=99. However, I am just confounded as to why the LT=14 isn't being satisfied on these two days. Any thoughts?

Sorry to be so long-winded but I wanted to toss out as much detail as possible in the event something is being overlooked.
rickaroo99
 
Posts: 1
Joined: Sat Jul 18, 2009 4:44 pm
Has thanked: 0 time
Been thanked: 0 time

Re: Job Dependency Lead Time Not Satisfied

 

Re: Job Dependency Lead Time Not Satisfied

Postby dick scherrer » Mon Jul 20, 2009 4:46 am

Hello and welcome to the forum,

Please check your PM inbox.

d
User avatar
dick scherrer
Global moderator
 
Posts: 6304
Joined: Sat Jun 09, 2007 8:58 am
Has thanked: 3 times
Been thanked: 91 times

Re: Job Dependency Lead Time Not Satisfied

Postby BaghdadMedic » Wed Aug 26, 2009 1:17 am

Did this get fixed? If not I can explain a work around.
BaghdadMedic
 
Posts: 11
Joined: Wed Jul 22, 2009 7:17 pm
Has thanked: 0 time
Been thanked: 0 time

Re: Job Dependency Lead Time Not Satisfied

Postby jonnie » Fri Sep 18, 2009 3:24 pm

Dont know if you solved this, but it could be a "since the last successfull run" problem.If job B ran it would check for its predecessor, if it sees it in the lead time it will run. If job B comes in again and it's previous run was successfull it won't run again even if still within the 14 hour leadtime. It will wait for another instance of the predecessor.

Hope this helps.

jonnie
jonnie
 
Posts: 3
Joined: Thu Jul 23, 2009 7:51 pm
Has thanked: 0 time
Been thanked: 0 time

Re: Job Dependency Lead Time Not Satisfied

Postby BaghdadMedic » Sat Sep 26, 2009 2:05 am

True,

Change the lead time to all zeros!
(Have you ran since the last time I ran) works with lead times of all zeros...
BaghdadMedic
 
Posts: 11
Joined: Wed Jul 22, 2009 7:17 pm
Has thanked: 0 time
Been thanked: 0 time


Return to CA-7

 


  • Related topics
    Replies
    Views
    Last post