HTML format in XMITIP



JES, JES2, JCL utilities, IDCAMS, Compile & Run JCLs, PROCs etc...

HTML format in XMITIP

Postby srrc » Wed Apr 12, 2017 2:15 pm

Dear All,
Hope all are doing great.
I am trying to send a mail from mainframe using XMITIP.
Below is the XMITIP code:
%XMITIP *     -
ADDRESSFILEDD ADRESSE -
MSG72 -
MSGDD MSGDD -
PRIORITY NORMAL -
FORMAT (HTML) -
FROM XXXX.YYY@ABCDE.COM -
SUBJECT 'TAR BATCH - &DATE / &TIME'

In ADRESSE , i have given to email ID.
In MSGDD i have given the below code with has HTML tags on it.
<HTML><HEAD><STYLE>
TABLE { BORDER: 3PX SOLID BLACK;BORDER-COLLAPSE: COLLAPSE;
TEXT-ALIGN: CENTER;MARGIN-LEFT:14PX;PADDING: 3PX; }
TD { BORDER: 1PX SOLID BLACK; BORDER-COLLAPSE: COLLAPSE;
TEXT-ALIGN: CENTER; FONT-SIZE: 090%; PADDING: 3PX; }
TH { BORDER: 1PX SOLID BLACK; BORDER-COLLAPSE: COLLAPSE;
TEXT-ALIGN: CENTER; PADDING: 5PX; FONT-SIZE: 100%;
BACKGROUND-COLOR: DARKTURQUOISE; COLOR: WHITE; }
</STYLE> </HEAD>
<BODY> <P> HI TEAM,</P>
<P>PLEASE FIND BELOW BATCH DETAILS:</P>
<TABLE>
<TR><TH>AAA_DATE</TH><TH>BBBB</TH><TH>CCCC</TH>
<TR>
<TD>12</TD>
<TD>XZ </TD>
<TD>12.04.2017</TD>
</TABLE>
<P>THANKS</P></BODY></HTML>


Am receiving the mail but not in the HTML i have formatted.

can anyone help me, i have mentioned FORMAT as HTML.

Thanks in advance.
srrc
 
Posts: 12
Joined: Tue Mar 28, 2017 1:43 pm
Has thanked: 2 times
Been thanked: 0 time

Re: HTML format in XMITIP

 

Re: HTML format in XMITIP

Postby florian29 » Thu May 11, 2017 7:23 pm

Hello,

Same question for me. After manny tests, i've finally used :

%XMITIP (usermail) +
   SUBJECT 'Your subjectt' +
   MSGDD your_dd_name +
   HTML


It works!
florian29
 
Posts: 1
Joined: Thu May 11, 2017 7:19 pm
Has thanked: 0 time
Been thanked: 0 time


Return to JCL

 


  • Related topics
    Replies
    Views
    Last post