Continuation Problem in JCL



JES, JES2, JCL utilities, IDCAMS, Compile & Run JCLs, PROCs etc...

Continuation Problem in JCL

Postby fornanthakumar » Wed Jan 19, 2011 3:08 am

Hi,

I have JCL like below,

1. //YBEQFTPD JOB (034G000,SF),SBEQ,CLASS=H,       
2. //         MSGCLASS=I,NOTIFY=YBEQ,             
3. //         RESTART=*                           
4. //********************************************************
5. //*                                                                    *
6. //SBEQFTPD EXEC SBEQFTPD   


When this JCL submitted in Production environment , it ABENDed with Continuation not received in line 6 as we have non-blank character at 72nd column in 5th line.

But when i was executing the same JCL in test environment it was not ABENDed. Why ? Is there any system installation check at background or JES2 or JES3..
because i can assume it may expect any JES2 or JES3 command as its blank from 4th column but.. you have to answer me..

FYI : My JOB submitted in JES2 for processing.
Regards,
Nanthu.Y.
fornanthakumar
 
Posts: 70
Joined: Fri Oct 22, 2010 1:58 pm
Has thanked: 0 time
Been thanked: 0 time

Re: Continuation Problem in JCL

 

Re: Continuation Problem in JCL

Postby dick scherrer » Wed Jan 19, 2011 3:20 am

Hello,

There is probably more in the sysout that we would need to see in order to help.

The same jcl works fine on my system. . .
Hope this helps,
d.sch.
User avatar
dick scherrer
Global moderator
 
Posts: 6304
Joined: Sat Jun 09, 2007 8:58 am
Has thanked: 3 times
Been thanked: 91 times

Re: Continuation Problem in JCL

Postby steve-myers » Wed Jan 19, 2011 3:59 am

If you look at line 5 you will find a character at the far right, possibly in column 72. If it is in column 72, that indicates line 6 is a continuation, not a new JCL statement, and that could well be the problem. Was it really the same JCL?
steve-myers
Global moderator
 
Posts: 1885
Joined: Thu Jun 03, 2010 6:21 pm
Has thanked: 4 times
Been thanked: 197 times

Re: Continuation Problem in JCL

Postby Anuj Dhawan » Fri Jan 21, 2011 6:08 pm

But when i was executing the same JCL in test environment it was not ABENDed. Why ? Is there any system installation check at background or JES2 or JES3..
To answer the "why" - you got to prove that both the Jobs were same. Post the SYSOUT of failed job as Dick has asked for. On the other hand, there are intellignet JCL-syntax check tool in market now and they flag it as an error if there is some-character in 72nd column. e.g.: This

=COLS> ----+----1----+----2----+----3----+----4----+----5----+----6----+----7--
000005 // JCLLIB ORDER=(HLQ.SLQ.PROCLIB.NEW)                                  *
==MSG> // JCLLIB ORDER=(HLQ.SLQ.PROCLIB.NEW)                               
==MSG> CAY6020E EXPECTED CONTINUATION NOT RECEIVED                             

flagged me an error, though such syntax-check-tools vary shop-to-shop with good differences, so to have a look on the SYSOUT of your failed is the only thing I can think of can help us to help you.
Anuj
Anuj Dhawan
 
Posts: 274
Joined: Mon Feb 25, 2008 3:53 am
Location: Mumbai, India
Has thanked: 6 times
Been thanked: 4 times

Re: Continuation Problem in JCL

Postby NicC » Fri Jan 21, 2011 6:47 pm

I doubt if the same JCL was submitted in a production environment - different RACF authorities, HLQs etc. so the JCL would have to have been altered in some respect.
The problem I have is that people can explain things quickly but I can only comprehend slowly.
Regards
Nic
NicC
Global moderator
 
Posts: 2690
Joined: Sun Jul 04, 2010 12:13 am
Location: Pushing up the daisys (almost)
Has thanked: 4 times
Been thanked: 105 times

Re: Continuation Problem in JCL

Postby fornanthakumar » Wed Jan 26, 2011 5:31 am

Thanks for all your replies. The mistake is from my side. The actuall error had occured in different line for the same reason as mentioned by anuj dhawan.
Regards,
Nanthu.Y.
fornanthakumar
 
Posts: 70
Joined: Fri Oct 22, 2010 1:58 pm
Has thanked: 0 time
Been thanked: 0 time

Re: Continuation Problem in JCL

Postby dick scherrer » Wed Jan 26, 2011 8:28 am

Good to hear it is working - thank you for letting us know :)

d
User avatar
dick scherrer
Global moderator
 
Posts: 6304
Joined: Sat Jun 09, 2007 8:58 am
Has thanked: 3 times
Been thanked: 91 times


Return to JCL

 


  • Related topics
    Replies
    Views
    Last post