Problem sending a seq. file as an email attachment



JES, JES2, JCL utilities, IDCAMS, Compile & Run JCLs, PROCs etc...

Re: Problem sending a seq. file as an email attachment

Postby Robert Sample » Sat Oct 20, 2012 7:55 pm

SMTP does not recognize mainframe file line numbers. Hence having line numbers in your data will cause SMTP to treat them as commands and, understandably, get a bit confused.
Robert Sample
Global moderator
 
Posts: 3367
Joined: Sat Dec 19, 2009 8:32 pm
Location: Dubuque, Iowa, USA
Has thanked: 1 time
Been thanked: 222 times

Re: Re: Problem sending a seq. file as an email attachment

 

Re: Problem sending a seq. file as an email attachment

Postby Balesh013GG » Sat Oct 20, 2012 10:07 pm

Thanks guys for all your help and time. Its working fine for me now.
Balesh013GG
 
Posts: 20
Joined: Fri Oct 19, 2012 4:21 pm
Has thanked: 0 time
Been thanked: 0 time

Re: Problem sending a seq. file as an email attachment

Postby dick scherrer » Sun Oct 21, 2012 9:25 am

Good to hear it is working - thanks for letting us know :)

If you post what you submitted, it will probably help someone eose with a similar problem one day ;)

d
User avatar
dick scherrer
Global moderator
 
Posts: 6304
Joined: Sat Jun 09, 2007 8:58 am
Has thanked: 3 times
Been thanked: 91 times

Re: Problem sending a seq. file as an email attachment

Postby Balesh013GG » Tue Oct 23, 2012 2:22 pm

Hello, Sorry to ask this question but this is very much essential. I am getting the email with attachemnt as per my requirement, but the its taking hours of time.. Is there any particular reason for that ?

//STD OUTPUT DEST=VIEW,ROOM=NAS,JESDS=ALL,DEFAULT=YES
//STD0 OUTPUT DEST=NONPRINT,DEFAULT=YES,JESDS=ALL
//NASC OUTPUT DEST=(SMTP),CLASS=A
//DUMP OUTPUT DEST=NONPRINT,FORMS=STD

would please someone let me know if any of the above statement make a differenece to the delivery.
Balesh013GG
 
Posts: 20
Joined: Fri Oct 19, 2012 4:21 pm
Has thanked: 0 time
Been thanked: 0 time

Re: Problem sending a seq. file as an email attachment

Postby BillyBoyo » Tue Oct 23, 2012 3:16 pm

If it runs but the e-mail only appears at its destination "hours later", then take it up with your support people. They will be able to tell you where it is being delayed, and what (if anything) you can do about it.
BillyBoyo
Global moderator
 
Posts: 3804
Joined: Tue Jan 25, 2011 12:02 am
Has thanked: 22 times
Been thanked: 264 times

Previous

Return to JCL

 


  • Related topics
    Replies
    Views
    Last post