timestamp error in SQLRPGLE



IBM OS/370, MVS, OS/390, Linux, TPF, VM/CMS, VM/ESA, VSE/ESA, z/VM, z/VSE, z/OS, z/OS.e etc...

timestamp error in SQLRPGLE

Postby s.jain416 » Thu Sep 30, 2010 10:49 am

H ALWNULL(*USRCTL)
H CVTOPT(*VARCHAR)
H DATEDIT(*YMD)
H FIXNBR(*ZONED : *INPUTPACKED)
H OPTION(*NODEBUGIO)
H SRTSEQ(*LANGIDSHR)
D********************************************************************
D* Work Fields
D* -----------
D DFTDTTM S Z INZ(Z'0001-01-01-00.00.00.000000')
D********************************************************************
C DFTDTTM DSPLY
C/EXEC SQL
C+ INSERT INTO MULTITMP1 (ORG,LOGO,TOTAL,STARTTIME,ENDTIME)
C+ SELECT ORG,LOGO,count(*), :DFTDTTM, :DFTDTTM FROM ATRF
C+ GROUP BY ORG,LOGO
C+ ORDER BY ORG,LOGO
C+ WITH NC
C/END-EXEC
C Seton LR

In this code wat value STARTTIME,ENDTIME will give coa m getting only intialize value while i should get system date/timestamp value.

Kindly let me know wat vto do for this
s.jain416
 
Posts: 3
Joined: Thu Sep 30, 2010 9:55 am
Has thanked: 0 time
Been thanked: 0 time

Re: timestamp error in SQLRPGLE

 

Re: timestamp error in SQLRPGLE

Postby enrico-sorichetti » Thu Sep 30, 2010 11:27 am

and do not triple post to unrelated forums
cheers
enrico
When I tell somebody to RTFM or STFW I usually have the page open in another tab/window of my browser,
so that I am sure that the information requested can be reached with a very small effort
enrico-sorichetti
Global moderator
 
Posts: 2886
Joined: Fri Apr 18, 2008 11:25 pm
Has thanked: 0 time
Been thanked: 153 times


Return to Operating Systems