user issues since applying security patches



Discuss about all tools related to Mainframes but usable in a PC/Computer like Mainframe Simulators, Emulators, Abend Assist etc...

user issues since applying security patches

Postby brucemchendry » Tue Nov 22, 2016 10:14 pm

Hello,
Hoping this is the right forum. At Sun Life (SLF) we have users using Personal Communications emulator to access their main frame apps. Recently I became the in house owner of this and with that came 3 patches that were overdue to be applied. We used our SCCM team to package up and start testing / piloting v 6.0.16 to apply these patches. Since they have been distributed to about 200 pilot testers a handful have an issue when they use TSO and download files. At a high level these users are telling me that they go and start to transfer a file. They add / change / rename as they need to but when the transfer happens it ignores the name and adds "bin" on the end. The filename is supposed to be 'JUTEST.SHAREPOL.V161110 and they have chosen "text" as the transfer type.
Here's an excerpt from one of the users.
Receiving file from host it is adding bin to the end of the first line and removing my single quotes.
Note I have tried this in TSO and ATSO (ATSO using file JUTEST.SHARE.FLX.V161110) and they both are removing the last single quote and adding bin to the file name
In addition the user manually changed the name and type again and when they go to download they get an error. INDFT018 -> TRANS18 Incorrect option specified file transfer cancelled.
The user manually removed the "bin" off the end of the file name and it seems to work then. I'm trying to do more testing to see if we can replicate the issue.
Platforms are :
Users are on Windows 7
Files transfer via Windows FTP server
Pcomm client is being patched from v6.0.1 to v6.0.16
Patches are : CVE - 2014 - 3566 and CVE - 2015 - 0138 and CVE - 2015 - 2808 ( getting old now but at least we're getting around to it )
Cheers,
Bruce
brucemchendry
 
Posts: 1
Joined: Tue Nov 22, 2016 8:50 pm
Has thanked: 0 time
Been thanked: 0 time

Re: user issues since applying security patches

 

Return to Simulators & Emulators

 


  • Related topics
    Replies
    Views
    Last post