Extraneous parameters error in 3.4 for a catalog entry



TSO Programming, ISPF, SDF, SDSF and PDF, FTP, TCP/IP Concepts, SNA & SNA/IP etc...

Extraneous parameters error in 3.4 for a catalog entry

Postby Murali_721 » Fri Nov 29, 2019 1:42 am

Hi,

I have come across a orphaned catalog entry as depicted in the image. This catalog is throwing Extraneous parameters error for any action taken against it. Can somebody explain what it is and how to get rid of this.
Murali_721
 
Posts: 4
Joined: Thu Nov 28, 2019 11:25 pm
Has thanked: 0 time
Been thanked: 0 time

Re: Extraneous parameters error in 3.4 for a catalog entry

 

Re: Extraneous parameters error in 3.4 for a catalog entry

Postby willy jensen » Fri Nov 29, 2019 3:31 am

I would like to see the command(s) that you have tried together with the result. 'Extraneous parameters' sounds a lot like syntax error.
By the way,I cant see any image.
willy jensen
 
Posts: 271
Joined: Thu Mar 10, 2016 5:03 pm
Has thanked: 0 time
Been thanked: 40 times

Re: Extraneous parameters error in 3.4 for a catalog entry

Postby Murali_721 » Fri Nov 29, 2019 3:48 am

Here is the image:
You do not have the required permissions to view the files attached to this post.
Murali_721
 
Posts: 4
Joined: Thu Nov 28, 2019 11:25 pm
Has thanked: 0 time
Been thanked: 0 time

Re: Extraneous parameters error in 3.4 for a catalog entry

Postby willy jensen » Fri Nov 29, 2019 4:00 am

Have you tried to enter HELP? I wonder where those 2 '0' in the line coms from. Though I can put as many '0' on a 3.4 line as I like and still get the popup.
Anyway, an orphaned catalog entry is usually gotten rid of by the 'U' line command, or perhaps using DELETE / NOSCRATCH as line command.
willy jensen
 
Posts: 271
Joined: Thu Mar 10, 2016 5:03 pm
Has thanked: 0 time
Been thanked: 40 times

Re: Extraneous parameters error in 3.4 for a catalog entry

Postby Murali_721 » Fri Nov 29, 2019 4:09 am

I'm explicitly specifying volume name to get this dataset in 3.4. Otherwise it says dataset not found. After specifying DS and Volume name together, there will be 1 '0' along with DS name separated by few columns. If i try any action, it would give me Extraneous parameters error and 2nd 0 appears.
Murali_721
 
Posts: 4
Joined: Thu Nov 28, 2019 11:25 pm
Has thanked: 0 time
Been thanked: 0 time

Re: Extraneous parameters error in 3.4 for a catalog entry

Postby Murali_721 » Fri Nov 29, 2019 4:13 am

This is the single line i gotten from HELP : "Extraneous parameters for built-in command"
Murali_721
 
Posts: 4
Joined: Thu Nov 28, 2019 11:25 pm
Has thanked: 0 time
Been thanked: 0 time

Re: Extraneous parameters error in 3.4 for a catalog entry

Postby Pedro » Wed Dec 04, 2019 5:23 am

I have come across a orphaned catalog entry as depicted in the image.

I think it is the opposite: it is an uncataloged data set. I think 3.4 has a line command to catalog it; use specific line command rather than '/'. Or use DEFINE NONVSAM command. Once it is cataloged, then delete it.
Pedro Vera
User avatar
Pedro
 
Posts: 599
Joined: Thu Jul 31, 2008 9:59 pm
Location: Silicon Valley
Has thanked: 0 time
Been thanked: 43 times

Re: Extraneous parameters error in 3.4 for a catalog entry

Postby steve-myers » Wed Dec 04, 2019 9:27 am

Pedro wrote:
I have come across a orphaned catalog entry as depicted in the image.

I think it is the opposite: it is an uncataloged data set. I think 3.4 has a line command to catalog it; use specific line command rather than '/'. Or use DEFINE NONVSAM command. Once it is cataloged, then delete it.

Pedro, I very much doubt that will work. I think the 0 0 stuff is extraneous junk that got into DS1DSNAM in the VTOC. Deleting the data set will be very difficult. Not impossible, but difficult. Because of the extraneous junk the data set cannot be cataloged. I know what I'd do, but I have tools I could use that are not generally available, so I can't tell people what I'd do.

Well, good luck to the TS.
steve-myers
Global moderator
 
Posts: 2038
Joined: Thu Jun 03, 2010 6:21 pm
Has thanked: 4 times
Been thanked: 221 times

Re: Extraneous parameters error in 3.4 for a catalog entry

Postby Pedro » Wed Dec 04, 2019 11:46 am

I am retired.. I do not have access anymore to verify.

Good catch about that name having zeros. I think you can use single quotes in JCL to specify nonstandard names:

//DEL1  DD DISP=(OLD,DELETE),
//      DSN='MY.DSN    0  0'
 


Just make sure you count all of embedded blanks correctly.
Pedro Vera
User avatar
Pedro
 
Posts: 599
Joined: Thu Jul 31, 2008 9:59 pm
Location: Silicon Valley
Has thanked: 0 time
Been thanked: 43 times

Re: Extraneous parameters error in 3.4 for a catalog entry

Postby willy jensen » Wed Dec 04, 2019 3:36 pm

Yeah I also missed that about the name having zeros.
Mayby a IEHLIST LISVTOC will show if the name has unprintable characters in it?
willy jensen
 
Posts: 271
Joined: Thu Mar 10, 2016 5:03 pm
Has thanked: 0 time
Been thanked: 40 times

Next

Return to TSO & ISPF

 


  • Related topics
    Replies
    Views
    Last post