printing '&'



TSO Programming, ISPF, SDF, SDSF and PDF, FTP, TCP/IP Concepts, SNA & SNA/IP etc...

printing '&'

Postby srn123 » Thu Aug 27, 2009 9:33 am

Hi All,

I am facing issues while coding jcl skeletons in REXX. I need to write the below line on to a dataset -
//SYSABOUT DD SYSOUT=&SOUT01.
When I try to run the macro I get only part of the line //SYSABOUT DD SYSOUT= . The part of line after the ampersand sign is not coming in the output.
Could you please let me know how I should modify the line so that I can get &SOUT01 in the line too?

Below is the complete code -

/* REXX */     
ADDRESS ISREDIT                                                     
 'MACRO'                                                             
 '(SAVE) = USER_STATE'                                               
 'RESET'                                                             
 /*GET LINE NUMBER WHERE LABEL K IS SET ELSE DISPLAY ERROR MESSAGE */
 '(LN) = LINENUM .K'                                                 
 IF RC = 8 THEN                                                       
    DO                                                               
     SAY "LABEL K NOT FOUND"                                         
     EXIT                                                             
    END                                                               
 "LINE_AFTER " LN " =  '//SYSABOUT  DD SYSOUT=&SOUT01'"   
'USER_STATE = (SAVE)'   


The macro prints only - //SYSABOUT DD SYSOUT=

Thanks
srn123
 
Posts: 13
Joined: Wed Aug 26, 2009 6:07 pm
Has thanked: 0 time
Been thanked: 0 time

Re: printing '&'

 

Return to TSO & ISPF