Using SDSF,prefix * COMMAND NOT AUTHORIZED



TSO Programming, ISPF, SDF, SDSF and PDF, FTP, TCP/IP Concepts, SNA & SNA/IP etc...

Using SDSF,prefix * COMMAND NOT AUTHORIZED

Postby david » Thu Aug 12, 2010 1:12 pm

When run the job:
//GETSTEP EXEC PGM=SDSF,COND=(4,LT)
//SYSPRINT DD SYSOUT=*
//ISFOUT DD DSN=TMAP006.BAT.ISFOUT,DISP=(NEW,CATLG),UNIT=3390,
// VOL=SER=SYSNEW,
// DCB=(RECFM=FB,LRECL=80,BLKSIZE=27920),
// SPACE=(TRK,(30,30))
//ISFIN DD *
SET CONFIRM OFF
OWNER *
ST
PREFIX *
FILTER JOBID JOB02814
++S
PRINT ODSN 'TMAP006.BAT.SRCLIB(RESULT)'
PRINT 1 999999
PRINT CLOSE
END
/*
FILE ISFOUT can find this:
STATUS DISPLAY ALL CLASSES COMMAND NOT AUTHORIZED
ND INPUT ===> PREFIX * SCROLL ===> PAG
JOBNAME JobID Owner Prty Queue C Pos SAff ASys Status
TMAP006 TSU03446 TMAP006 15 EXECUTION ADCD ADCD

But I can use prefix * in sdsf like this:
SDSF STATUS DISPLAY ALL CLASSES
COMMAND INPUT ===> prefix *
NP JOBNAME JobID Owner Prty Queue

Help me.
david
 
Posts: 8
Joined: Tue Aug 10, 2010 8:30 pm
Has thanked: 0 time
Been thanked: 0 time

Re: Using SDSF,prefix * COMMAND NOT AUTHORIZED

 

Re: Using SDSF,prefix * COMMAND NOT AUTHORIZED

Postby NicC » Thu Aug 12, 2010 2:23 pm

Quite often batch versions of utilities will have different authorisations from online. First thing to do would be to check with your sysprogs/security people.
The problem I have is that people can explain things quickly but I can only comprehend slowly.
Regards
Nic
NicC
Global moderator
 
Posts: 2690
Joined: Sun Jul 04, 2010 12:13 am
Location: Pushing up the daisys (almost)
Has thanked: 4 times
Been thanked: 105 times

Re: Using SDSF,prefix * COMMAND NOT AUTHORIZED

Postby david » Thu Aug 12, 2010 3:28 pm

OK.TKS. NicC
david
 
Posts: 8
Joined: Tue Aug 10, 2010 8:30 pm
Has thanked: 0 time
Been thanked: 0 time

Re: Using SDSF,prefix * COMMAND NOT AUTHORIZED

Postby bighurt92 » Fri Sep 06, 2013 11:21 pm

Can anyone post a solution to this issue? I am experiencing the same issue today. I am a fairly new Systems Programmers and we just recently performed a z/os upgrade from 1.7 to 1.11, that's when this issue started occurring. Unfortunately my shop is very small and there are only 2 people that manage the mainframe so my colleague and I are the sysprogs/security people and of course this issue surfaced when my more experienced colleague is out of town. Any assistance will be greatly appreciated.
bighurt92
 
Posts: 2
Joined: Fri Sep 06, 2013 8:07 pm
Has thanked: 1 time
Been thanked: 0 time

Re: Using SDSF,prefix * COMMAND NOT AUTHORIZED

Postby Pedro » Fri Sep 06, 2013 11:40 pm

Search the SDSF manual for 'COMMAND NOT AUTHORIZED'. I think the explanation of the message will refer you to the section of how to setup the authorizations.

IBM manuals are here:
http://www-03.ibm.com/systems/z/os/zos/bkserv/r13pdf/
Pedro Vera

These users thanked the author Pedro for the post:
bighurt92 (Mon Sep 16, 2013 10:47 pm)
User avatar
Pedro
 
Posts: 569
Joined: Thu Jul 31, 2008 9:59 pm
Location: Silicon Valley
Has thanked: 0 time
Been thanked: 39 times

Re: Using SDSF,prefix * COMMAND NOT AUTHORIZED

Postby bighurt92 » Mon Sep 16, 2013 10:46 pm

Thanks Pedro this let me to a usermod that had not been applied to the new system.
bighurt92
 
Posts: 2
Joined: Fri Sep 06, 2013 8:07 pm
Has thanked: 1 time
Been thanked: 0 time

Re: Using SDSF,prefix * COMMAND NOT AUTHORIZED

Postby dick scherrer » Tue Sep 17, 2013 8:20 pm

Hello and welcome to the forum,

Thank you for posting the resolution :)

d
User avatar
dick scherrer
Global moderator
 
Posts: 6304
Joined: Sat Jun 09, 2007 8:58 am
Has thanked: 3 times
Been thanked: 91 times


Return to TSO & ISPF

 


  • Related topics
    Replies
    Views
    Last post