Need help to address the issue



TSO Programming, ISPF, SDF, SDSF and PDF, FTP, TCP/IP Concepts, SNA & SNA/IP etc...

Need help to address the issue

Postby XY09 » Sat Jan 08, 2011 12:04 pm

Hi All,

I found the below error while reading SYSLOG. What is the error and what is the reason the error will come in the SYSLOG. I searched in the google but no luck. please help me in this regrad.


IKJ56294I SUBMIT ENDED DUE TO ERROR, SYSTEM ABEND CODE 13E
IKJ56292I UNABLE TO ISSUE FAILURE MESSAGE TO TERMINAL BECAUSE PUTLINE WAS UNSUCCESSFUL FOR IKJEFF19
GNRLFAIL/VSAMFAIL ROUTINE
IKJ56293I SUBMIT FAILED - PUTLINE SERVICE ROUTINE HAD DISCONNECTED TERMINAL DETECTED+
IKJ56293I RETRY, THEN IF ERROR CALL YOUR SYSTEM PROGRAMMER (REGISTER 15 = X'00000014')
+IKJ79203I SUBMIT COMMAND ENDED DUE TO ERROR+
+IKJ79203I SUBMIT COMMAND ENDED DUE TO ERROR+
+IKJ56286I SYSTEM OR INSTALLATION ERROR. REPORT THE FOLLOWING MESSAGE TO YOUR TSO ADMINISTRATOR
+IKJ56284I UNABLE TO ISSUE MESSAGE TO TERMINAL 106A BECAUSE PUTLINE WAS UNSUCCESSFUL
+IKJ56293I IKJEF02R FAILED - PUTLINE SERVICE ROUTINE HAD DISCONNECTED TERMINAL DETECTED+
+IKJ56293I RETRY, THEN IF ERROR CALL YOUR SYSTEM PROGRAMMER (REGISTER 15 = 20)

xy09
XY09
 
Posts: 25
Joined: Mon Apr 26, 2010 9:19 am
Has thanked: 0 time
Been thanked: 0 time

Re: Need help to address the issue

 

Re: Need help to address the issue

Postby steve-myers » Sat Jan 08, 2011 5:44 pm

What's so hard to understand about -

IKJ56293I SUBMIT FAILED - PUTLINE SERVICE ROUTINE HAD DISCONNECTED TERMINAL DETECTED ?

For some reason your terminal got disconnected while the SUBMIT command was executing.
steve-myers
Global moderator
 
Posts: 1944
Joined: Thu Jun 03, 2010 6:21 pm
Has thanked: 4 times
Been thanked: 209 times

Re: Need help to address the issue

Postby Robert Sample » Sat Jan 08, 2011 7:14 pm

The message even tell you -- very specifically -- what to do:
+IKJ56293I RETRY, THEN IF ERROR CALL YOUR SYSTEM PROGRAMMER (REGISTER 15 = 20)
and strangely enough I do not see in the message anywhere about posting to a forum ....
Robert Sample
Global moderator
 
Posts: 3524
Joined: Sat Dec 19, 2009 8:32 pm
Location: Dubuque, Iowa, USA
Has thanked: 1 time
Been thanked: 251 times

Re: Need help to address the issue

Postby steve-myers » Sun Jan 09, 2011 1:58 am

Most dedicated TSO commands use a service routine called PUTLINE to send messages to the TSO terminal rather than use the TPUT macro. If you are running the TSO Terminal Monitor in batch PUTLINE will automatically send the message to the SYSTSPRT data set. Another advantage of PUTLINE is it is AMODE and RMODE agnostic; the TPUT macro requires the actual message be below the 16-megabyte line. There are other advantages to PUTLINE, though it is more difficult to use than TPUT in other respects.

Although I'm one of the few dinosaurs that still write line mode TSO commands, I rarely use PUTLINE. I use another TSO service routine called IKJEFF02 to generate and write messages using PUTLINE.
steve-myers
Global moderator
 
Posts: 1944
Joined: Thu Jun 03, 2010 6:21 pm
Has thanked: 4 times
Been thanked: 209 times


Return to TSO & ISPF

 


  • Related topics
    Replies
    Views
    Last post