Send email through mainframe



TSO Programming, ISPF, SDF, SDSF and PDF, FTP, TCP/IP Concepts, SNA & SNA/IP etc...

Send email through mainframe

Postby bodhi » Wed Sep 19, 2007 8:34 pm

Hi all i am trying to send a email through mainframe. i pasted the code which i am using below:

//VSMAILS JOB (1,68983,FOC-625),
// USER=&SYSUID,NOTIFY=&SYSUID,
// MSGCLASS=9
//SENDNOTE EXEC PGM=IEBGENER
//SYSIN DD DUMMY
//SYSUT1 DD *
HELO VIST010.VIPDIST123
MAIL FROM:<FROM.MAIL.COM >
RCPT TO:<TO.MAIL.COM>
DATA
TO: TO.MAIL.COM
SUBJECT: TEST MESSAGE
TEST MESSAGE
/*
//SYSUT2 DD SYSOUT=K,DEST=TCPSMTP
//SYSOUT DD SYSOUT=*
//SYSPRINT DD SYSOUT=*

WHEN I AM USING JSCAN TO FIND THE ERROR IT GIVE ("TCPSMTP " IS AN INVALID REMOTE DESTINATION ) BUT IF I SUBMIT THE JOB,IT WENT FINE BUT NO MAIL SENT THROUGH THIS.

THANKS IN ADVANCE
BODHI


CAN ANYBODY HELP ME WHERE I WENT WORNG
bodhi
 
Posts: 53
Joined: Mon Jul 30, 2007 5:01 pm
Has thanked: 0 time
Been thanked: 0 time

Re: Send email through mainframe

 

Re: MAIL FROM MAIMFRAME

Postby CICS Guy » Thu Sep 20, 2007 4:48 pm

bodhi wrote:WHEN I AM USING JSCAN TO FIND THE ERROR IT GIVE ("TCPSMTP " IS AN INVALID REMOTE DESTINATION ) BUT IF I SUBMIT THE JOB,IT WENT FINE BUT NO MAIL SENT THROUGH THIS.
Please try to remember to unlock your Caps...... :o
You could try to hide the destination in a symbolic.....that might fool the checker....
CICS Guy
 
Posts: 255
Joined: Wed Jun 20, 2007 4:08 am
Has thanked: 0 time
Been thanked: 0 time

Re: MAIL FROM MAIMFRAME

Postby Tzadik Vanderhoof » Thu Nov 15, 2007 2:48 am

Did this ever work?
Tzadik Vanderhoof
 
Posts: 21
Joined: Tue Nov 13, 2007 11:53 pm
Has thanked: 0 time
Been thanked: 0 time

Re: MAIL FROM MAIMFRAME

Postby dick scherrer » Thu Nov 15, 2007 3:29 am

Hello Tzadik,

Is your question about this particlar jcl/dest or sending an e-mail from the mainframe in general?

It is quite common to send an e-mail from the mainframe.
Hope this helps,
d.sch.
User avatar
dick scherrer
Global moderator
 
Posts: 6304
Joined: Sat Jun 09, 2007 8:58 am
Has thanked: 3 times
Been thanked: 91 times

Re: Send email through mainframe

Postby Tzadik Vanderhoof » Thu Nov 15, 2007 10:31 pm

Well, it looked like the person's question was never answered, so I'm wondering if this technique works. I'd certainly be interested in other techniques that work instead.
Tzadik Vanderhoof
 
Posts: 21
Joined: Tue Nov 13, 2007 11:53 pm
Has thanked: 0 time
Been thanked: 0 time

Re: Send email through mainframe

Postby MrSpock » Fri Nov 16, 2007 12:45 am

We use SAS. Of course, all that's required to send an SMTP message is some basic Socket programming.
User avatar
MrSpock
Global moderator
 
Posts: 810
Joined: Wed Jun 06, 2007 9:37 pm
Location: Raleigh NC USA
Has thanked: 0 time
Been thanked: 2 times

Re: Send email through mainframe

Postby Tzadik Vanderhoof » Fri Nov 16, 2007 3:17 am

Can that be done in COBOL?
Tzadik Vanderhoof
 
Posts: 21
Joined: Tue Nov 13, 2007 11:53 pm
Has thanked: 0 time
Been thanked: 0 time

Re: Send email through mainframe

Postby dick scherrer » Fri Nov 16, 2007 9:06 am

Hello,

You could try to hide the destination in a symbolic.....that might fool the checker....
That was the suggestion to get around the error. TS has not replied. . .

Can that be done in COBOL?
Yes, code to use sockets can be written in cobol, but many/most mainframe e-mails are simply sent from a batch tso job.
Hope this helps,
d.sch.
User avatar
dick scherrer
Global moderator
 
Posts: 6304
Joined: Sat Jun 09, 2007 8:58 am
Has thanked: 3 times
Been thanked: 91 times

Re: Send email through mainframe

Postby nazishmirekar » Wed Jul 16, 2008 11:03 am

I have tried sending emails through JCL. Though my job end with MAXCC = 0, i am not receiving mails. Do i need to check some MVS configuration?

Can any one give me more information?

Thanks,
Nazish.
nazishmirekar
 
Posts: 3
Joined: Tue Jul 15, 2008 11:37 am
Has thanked: 0 time
Been thanked: 0 time

Re: Send email through mainframe

Postby jayind » Wed Jul 16, 2008 2:18 pm

Hi nazishmirekar,

some setup needs to be done at SMTP to allow your email. You may need to check with your system admin (STG) people who deals with the email id creation, maintenance etc.. even i had this problem in one of my projects and i approached the STG people they did some configuration setup (which I am not aware) and it worked after that... Probably you need to check with them... This is my suggestion..

may be you can hear better solutions from others...

Regards,
Jayind
jayind
 
Posts: 62
Joined: Wed Apr 23, 2008 1:37 pm
Location: Chennai, India
Has thanked: 0 time
Been thanked: 0 time

Next

Return to TSO & ISPF

 


  • Related topics
    Replies
    Views
    Last post