Cluster - Load balancing problem



Support for MQSeries and Websphere Message Oriented Middleware communication systems for z/OS

Cluster - Load balancing problem

Postby solomon_13000 » Sun Jul 27, 2008 6:06 pm

crtmqm -q Dummy
crtmqm -q HKIP01S1
crtmqm -q HKIB01S1
crtmqm -q HKIB02S1
crtmqm -q QMB1
crtmqm -q QMB2

runmqsc Dummy

DEFINE QREMOTE(Dum) DESCR('') RNAME('') RQMNAME('') XMITQ(HKIP01S1.XMIT.DF)

DEFINE QLOCAL(HKIP01S1.XMIT.DF) DESCR('') TRIGDATA(TO.CLUS2.HKIB01S1) USAGE(XMITQ) TRIGGER TRIGTYPE(EVERY)

DEFINE CHANNEL(TO.CLUS2.HKIB01S1) CHLTYPE(SDR) DESCR('') CONNAME('localhost(2002)') XMITQ(HKIP01S1.XMIT.DF)


runmqsc HKIP01S1

DEFINE QREMOTE(CLUS2) RQMNAME('') RNAME('') XMITQ(HKIP01S1.XMIT.DF)

DEFINE QLOCAL(HKIP01S1.XMIT.DF) USAGE(XMITQ) TRIGDATA(TO.CLUS2.HKIP01S1) TRIGTYPE(EVERY) TRIGGER PUT(ENABLED) GET(ENABLED)

DEFINE CHANNEL(TO.CLUS2.HKIP01S1) CHLTYPE(SDR) TRPTYPE(TCP) CONNAME('localhost(1414)') XMITQ(HKIP01S1.XMIT.DF)

DEFINE CHANNEL(TO.CLUS2.HKIB01S1) CHLTYPE(RCVR) TRPTYPE(TCP)

DEFINE QLOCAL(QM.REPLY) USAGE(NORMAL) PUT(ENABLED) GET(ENABLED)


runmqsc HKIB01S1
ALTER QMGR REPOS(CLUS2)

DEFINE CHANNEL(TO.CLUS2.HKIP01S1) CHLTYPE(CLUSRCVR) TRPTYPE(TCP) CONNAME('localhost(1414)') SHORTRTY(600) SHORTTMR(60) DISCINT(30) CLUSTER(CLUS2) REPLACE

DEFINE CHANNEL(TO.CLUS2.HKIB01S1) CHLTYPE(CLUSSDR) TRPTYPE(TCP) CONNAME('localhost(1415)') SHORTRTY(600) SHORTTMR(60) DISCINT(30) CLUSTER(CLUS2) REPLACE


runmqsc HKIB02S1
ALTER QMGR REPOS(CLUS2)

DEFINE CHANNEL(TO.CLUS2.HKIP01S1) CHLTYPE(CLUSRCVR) TRPTYPE(TCP) CONNAME('localhost(1415)') SHORTRTY(600) SHORTTMR(60) DISCINT(30) CLUSTER(CLUS2) REPLACE

DEFINE CHANNEL(TO.CLUS2.HKIB01S1) CHLTYPE(CLUSSDR) TRPTYPE(TCP) CONNAME('localhost(1414)') SHORTRTY(600) SHORTTMR(60) DISCINT(30) CLUSTER(CLUS2) REPLACE


runmqsc QMB1

DEFINE QLOCAL(QMQ) DEFPSIST(YES) DEFBIND(NOTFIXED) CLUSTER(CLUS2) REPLACE

DEFINE CHANNEL(TO.CLUS2.HKIP01S1) CHLTYPE(CLUSSDR) TRPTYPE(TCP) CONNAME('localhost(1414)') SHORTRTY(600) SHORTTMR(60) DISCINT(30) CLUSTER(CLUS2) REPLACE

DEFINE CHANNEL(TO.CLUS2.HKIB01S1) CHLTYPE(CLUSRCVR) TRPTYPE(TCP) CONNAME('localhost(1416)') SHORTRTY(600) SHORTTMR(60) DISCINT(30) CLUSTER(CLUS2) REPLACE


runmqsc QMB2

DEFINE QLOCAL(QMQ) DEFPSIST(YES) DEFBIND(NOTFIXED) CLUSTER(CLUS2)

DEFINE CHANNEL(TO.CLUS2.HKIP01S1) CHLTYPE(CLUSSDR) TRPTYPE(TCP) CONNAME('localhost(1415)') SHORTRTY(600) SHORTTMR(60) DISCINT(30) CLUSTER(CLUS2) REPLACE

DEFINE CHANNEL(TO.CLUS2.HKIB01S1) CHLTYPE(CLUSRCVR) TRPTYPE(TCP) CONNAME('localhost(1417)') SHORTRTY(600) SHORTTMR(60) DISCINT(30) CLUSTER(CLUS2) REPLACE


-----------------------------------------------------------------------------------

When I attempted to put a value into the QREMOTE(Dum) on Dummy QM I am getting the error:

Sample AMQSPUT0 start
target queue is Dum
MQOPEN ended with reason code 2085
unable to open queue for output
Sample AMQSPUT0 end

Sample AMQSPUT0 start
MQCONN ended with reason code 2058

How do I solve this problem?.

Regards.
solomon_13000
 
Posts: 2
Joined: Sun Jul 27, 2008 6:02 pm
Has thanked: 0 time
Been thanked: 0 time

Re: Cluster - Load balancing problem

 

Re: Cluster - Load balancing problem

Postby solomon_13000 » Sun Jul 27, 2008 8:34 pm

I refine my MQ definition as below:

crtmqm -q HKIP01S1
crtmqm -q HKIB01S1
crtmqm -q HKIB02S1
crtmqm -q QMB1
crtmqm -q QMB2


runmqsc HKIP01S1

DEFINE QREMOTE(SERVER) RQMNAME('ANY.CLUSTER') RNAME('SERVER') XMITQ(HKIP01S1.XMIT.DF)

DEFINE QLOCAL(HKIP01S1.XMIT.DF) USAGE(XMITQ) TRIGDATA(TO.CLUS2.HKIP01S1) TRIGTYPE(EVERY) TRIGGER PUT(ENABLED) GET(ENABLED)

DEFINE CHANNEL(TO.CLUS2.HKIP01S1) CHLTYPE(SDR) TRPTYPE(TCP) CONNAME('localhost(1414)') XMITQ(HKIP01S1.XMIT.DF)

DEFINE CHANNEL(TO.CLUS2.HKIB01S1) CHLTYPE(RCVR) TRPTYPE(TCP)

DEFINE QLOCAL(QM.REPLY) USAGE(NORMAL) PUT(ENABLED) GET(ENABLED)


runmqsc HKIB01S1
ALTER QMGR REPOS(CLUS2)

DEFINE QREMOTE('ANY.CLUSTER') RQMNAME('') RNAME('') XMITQ('')

DEFINE CHANNEL(TO.CLUS2.HKIP01S1) CHLTYPE(CLUSRCVR) TRPTYPE(TCP) CONNAME('localhost(1414)') SHORTRTY(600) SHORTTMR(60) DISCINT(30) CLUSTER(CLUS2) REPLACE

DEFINE CHANNEL(TO.CLUS2.HKIB01S1) CHLTYPE(CLUSSDR) TRPTYPE(TCP) CONNAME('localhost(1415)') SHORTRTY(600) SHORTTMR(60) DISCINT(30) CLUSTER(CLUS2) REPLACE


runmqsc HKIB02S1
ALTER QMGR REPOS(CLUS2)

DEFINE QREMOTE('ANY.CLUSTER') RQMNAME('') RNAME('') XMITQ('')

DEFINE CHANNEL(TO.CLUS2.HKIP01S1) CHLTYPE(CLUSRCVR) TRPTYPE(TCP) CONNAME('localhost(1415)') SHORTRTY(600) SHORTTMR(60) DISCINT(30) CLUSTER(CLUS2) REPLACE

DEFINE CHANNEL(TO.CLUS2.HKIB01S1) CHLTYPE(CLUSSDR) TRPTYPE(TCP) CONNAME('localhost(1414)') SHORTRTY(600) SHORTTMR(60) DISCINT(30) CLUSTER(CLUS2) REPLACE


runmqsc QMB1

DEFINE QLOCAL(QMQ) DEFPSIST(YES) DEFBIND(NOTFIXED) CLUSTER(CLUS2) REPLACE

DEFINE CHANNEL(TO.CLUS2.HKIP01S1) CHLTYPE(CLUSSDR) TRPTYPE(TCP) CONNAME('localhost(1414)') SHORTRTY(600) SHORTTMR(60) DISCINT(30) CLUSTER(CLUS2) REPLACE

DEFINE CHANNEL(TO.CLUS2.HKIB01S1) CHLTYPE(CLUSRCVR) TRPTYPE(TCP) CONNAME('localhost(1416)') SHORTRTY(600) SHORTTMR(60) DISCINT(30) CLUSTER(CLUS2) REPLACE


runmqsc QMB2

DEFINE QLOCAL(QMQ) DEFPSIST(YES) DEFBIND(NOTFIXED) CLUSTER(CLUS2)

DEFINE CHANNEL(TO.CLUS2.HKIP01S1) CHLTYPE(CLUSSDR) TRPTYPE(TCP) CONNAME('localhost(1415)') SHORTRTY(600) SHORTTMR(60) DISCINT(30) CLUSTER(CLUS2) REPLACE

DEFINE CHANNEL(TO.CLUS2.HKIB01S1) CHLTYPE(CLUSRCVR) TRPTYPE(TCP) CONNAME('localhost(1417)') SHORTRTY(600) SHORTTMR(60) DISCINT(30) CLUSTER(CLUS2) REPLACE


-----------------------------------------------------------------------------------

amqsput SERVER HKIP01S1
Sample AMQSPUT0 start
target queue is SERVER
HELLO WORLD

Sample AMQSPUT0 end

works however it still remains in my HKIP01S1.XMIT.DF of HKIP01S1 instead of moving to the QMQ.
solomon_13000
 
Posts: 2
Joined: Sun Jul 27, 2008 6:02 pm
Has thanked: 0 time
Been thanked: 0 time


Return to WebSphere MQ

 


  • Related topics
    Replies
    Views
    Last post