Error while doing XPED/TSO



Compuware's QA & Impact Analysis Tools: Xpediter/CICS , Xpediter/TSO, Xpediter/DB2, Xpediter/Xchange, Xpediter/IMS

Error while doing XPED/TSO

Postby ajuatsgp » Thu Jun 24, 2010 2:53 pm

Hi,

While doing XPED/TSO I am encouterring following error

GO 1
XPD0576 RA051 ERROR WITH IEWBIND FUNC=SAVEW, ******* IS A PROGRAM OBJECT
AND THE XDYNAMIC DATASET IS A PDSE

the MVS I am working gives the following explanation for the above error
XPD0576 ERROR WITH IEWBIND FUNC=SAVEW, (module name) IS A ('PROGRAM
OBJECT' or 'LOAD MODULE') AND THE XDYNAMIC DATASET IS A ('PDS' or 'PDSE').

Module: ADSRA051

Explanation: A critical error occurred using the IEWBIND macro.

User Response: If you are using program objects and the XDYNAMIC dataset
is a PDS, make the XDYNAMIC dataset a PDSE. Otherwise contact Compuware
Technical Support. The XDYNAMIC 'Dataset type' can be changed via the test
panel by entering the SEtup, Extended, Work commands.


I have tried changing the XDYNAMIC datase to PDSE still getting same error.

Please help me how to resolve it.
ajuatsgp
 
Posts: 82
Joined: Thu May 20, 2010 6:50 pm
Has thanked: 0 time
Been thanked: 0 time

Re: Error while doing XPED/TSO

 

Re: Error while doing XPED/TSO

Postby Robert Sample » Thu Jun 24, 2010 5:06 pm

YOUR post tells you how to resolve it:
Otherwise contact Compuware Technical Support.
Robert Sample
Global moderator
 
Posts: 3367
Joined: Sat Dec 19, 2009 8:32 pm
Location: Dubuque, Iowa, USA
Has thanked: 1 time
Been thanked: 222 times

Re: Error while doing XPED/TSO

Postby ajuatsgp » Thu Jun 24, 2010 7:46 pm

Sir I tried that but not sure if the type of XDYNAMIC is changing from PDS tp PDSE or not.

And for this matter I can't contact my back end Technical support team hence I posted it here.

If anybody has any idea please help
ajuatsgp
 
Posts: 82
Joined: Thu May 20, 2010 6:50 pm
Has thanked: 0 time
Been thanked: 0 time

Re: Error while doing XPED/TSO

Postby Robert Sample » Thu Jun 24, 2010 8:15 pm

Sir I tried that but not sure if the type of XDYNAMIC is changing from PDS tp PDSE or not.
No reason not to look and tell yourself. When you go into Xpediter, one of your options is to Edit the JCL before submitting it. Do so and look for the XDYNAMIC statement:
//XDYNAMIC DD  DISP=(NEW,DELETE),
//             DSNTYPE=PDS,
//             UNIT=SYSDA,
//             DCB=(RECFM=U,DSORG=PO,BLKSIZE=32760),
//             SPACE=(CYL,(5,0,10))
This one is a PDS -- since DSNTYPE=LIBRARY is required for PDSE.

And for this matter I can't contact my back end Technical support team hence I posted it here.
Please notice that the message in your post does not indicate you should contact your technical support team but the Compuware support -- as long as your site has a legal license to Xpediter you can get support from Compuware for the product. If the DSNTYPE is LIBRARY in your JCL, you will have two choices -- contact Compuware for assistance or find some other way besides Xpediter to debug your code.
Robert Sample
Global moderator
 
Posts: 3367
Joined: Sat Dec 19, 2009 8:32 pm
Location: Dubuque, Iowa, USA
Has thanked: 1 time
Been thanked: 222 times


Return to Xpediter

 


  • Related topics
    Replies
    Views
    Last post