Help establishing a DB2 connection in Xpediter



Compuware's QA & Impact Analysis Tools: Xpediter/CICS , Xpediter/TSO, Xpediter/DB2, Xpediter/Xchange, Xpediter/IMS

Help establishing a DB2 connection in Xpediter

Postby MFFLCrime » Sat Aug 04, 2012 8:51 pm

Hi All,

I am trying to use Xpediter for a DB2 program. I am able to display the source and navigate through it, however, when I execute the first SQL command, the program abends with SQLCODE = -927. I believe it is because I am not able to establish a DB2 connection because the options to specify whether it is a DB2 test, the Plan and DB2 subsystem are not available in the ISPF Xpediter panel.

Is there a way to do this from within the program?

Please help! I have unsuccessfully searched for an answer everywhere.

Thanks
MFFLCrime
 
Posts: 8
Joined: Tue Jul 31, 2012 6:47 am
Has thanked: 0 time
Been thanked: 0 time

Re: Help establishing a DB2 connection in Xpediter

 

Re: Help establishing a DB2 connection in Xpediter

Postby NicC » Sun Aug 05, 2012 2:55 pm

Double-check that there is no DB2 entry on you entry panels. Double-check that there is not a separate menu item for Xpediter/DB2. If nothing then check with your colleagues to see if they can Xpedite a DB2 program. If that fails then ask your Xpediter support - it may be that the DB2 option has not been installed.
The problem I have is that people can explain things quickly but I can only comprehend slowly.
Regards
Nic
NicC
Global moderator
 
Posts: 2691
Joined: Sun Jul 04, 2010 12:13 am
Location: Pushing up the daisys (almost)
Has thanked: 4 times
Been thanked: 105 times

Re: Help establishing a DB2 connection in Xpediter

Postby Anuj Dhawan » Mon Aug 06, 2012 3:54 pm

Suggest you talk to your site-support group or some senior around. These set-ups are pretty site-specific and getting a to-the-point help via a Forum is very thin...
Anuj
Anuj Dhawan
 
Posts: 274
Joined: Mon Feb 25, 2008 3:53 am
Location: Mumbai, India
Has thanked: 6 times
Been thanked: 4 times

Re: Help establishing a DB2 connection in Xpediter

Postby MFFLCrime » Fri Aug 31, 2012 3:45 am

Hi All, I was able to resolve my issues in Xpediter and I am now able to debug DB2 programs.
MFFLCrime
 
Posts: 8
Joined: Tue Jul 31, 2012 6:47 am
Has thanked: 0 time
Been thanked: 0 time

Re: Help establishing a DB2 connection in Xpediter

Postby NicC » Fri Aug 31, 2012 1:05 pm

And the problem was? (It may help other people searching for the same reason as you)
The problem I have is that people can explain things quickly but I can only comprehend slowly.
Regards
Nic
NicC
Global moderator
 
Posts: 2691
Joined: Sun Jul 04, 2010 12:13 am
Location: Pushing up the daisys (almost)
Has thanked: 4 times
Been thanked: 105 times

Re: Help establishing a DB2 connection in Xpediter

Postby MFFLCrime » Sat Sep 01, 2012 2:57 am

My problem was not having the panel with the options to enter whether I was doing a DB2 test and having the ability to enter the Plan and DB2 Subsystem. I learned to avoid having to do this using the BATCH functionality.
MFFLCrime
 
Posts: 8
Joined: Tue Jul 31, 2012 6:47 am
Has thanked: 0 time
Been thanked: 0 time

Re: Help establishing a DB2 connection in Xpediter

Postby NicC » Sat Sep 01, 2012 4:39 pm

Thank you for that. It seems like there may be a setup problem with your installation. Check with your Xpediter support people.
The problem I have is that people can explain things quickly but I can only comprehend slowly.
Regards
Nic
NicC
Global moderator
 
Posts: 2691
Joined: Sun Jul 04, 2010 12:13 am
Location: Pushing up the daisys (almost)
Has thanked: 4 times
Been thanked: 105 times


Return to Xpediter

 


  • Related topics
    Replies
    Views
    Last post