CEE3204S The system detected a protection exception



IBM's cross-platform compiler PL/I for MVS, VM & VSE, OS/390 and Enterprise PL/I for z/OS

CEE3204S The system detected a protection exception

Postby rickyzeng » Thu Oct 29, 2009 7:19 pm

Hello guys,

We faced a problem, our job failed for few days with return code 1000, but the output has been generated successfully and sent out. We can not find out the root cause. it's strange because this job is correct before and we did not make any change on it.

Can some one help me to analyze below information?

Thanks in advance!

JOB00523 GSDMV21I JGRED410 RUN405 RTP020 1000 00:00:54

Snap dump was unsuccessful


CEE3204S The system detected a protection exception (System Completion Code=0C4)
Location:
Program Unit: Entry: C_EXTRACTION
Statement: Offset: +00000104


Storage dump near condition, beginning at location: 000681EC
+000000 000681EC A74AFFFF A74C000A 412011D0 41141264 D2091000 200C5810
GPREG STORAGE:
Storage around GPR0 (000000F0)
-0020 000000D0 Inaccessible storage.
+0000 000000F0 Inaccessible storage.
+0020 00000110 Inaccessible storage.
Storage around GPR1 (497BF9DC)
-0020 497BF9BC Inaccessible storage.
+0000 497BF9DC Inaccessible storage.
+0020 497BF9FC Inaccessible storage.
rickyzeng
 
Posts: 2
Joined: Thu Oct 29, 2009 7:05 pm
Has thanked: 0 time
Been thanked: 0 time

Re: CEE3204S The system detected a protection exception

Postby dick scherrer » Fri Oct 30, 2009 1:16 am

Hello,

Something is different in the abended run. . . Hopefully, if the same inputs are used, the abend will repeat.

Possibly some bad code that is just now discovered - an array gone wild perhaps.

Suggest you insert a bit of diagnostic code and determine where the abend happens.
Hope this helps,
d.sch.
User avatar
dick scherrer
Global moderator
 
Posts: 6269
Joined: Sat Jun 09, 2007 8:58 am
Has thanked: 3 times
Been thanked: 93 times

Re: CEE3204S The system detected a protection exception

Postby rickyzeng » Fri Oct 30, 2009 5:11 pm

Thank you very much, dick scherrer.

Following your guidance, i have found the bad code in the program.

it is due to the array go wild.

Thank you very much!
rickyzeng
 
Posts: 2
Joined: Thu Oct 29, 2009 7:05 pm
Has thanked: 0 time
Been thanked: 0 time

Re: CEE3204S The system detected a protection exception

Postby dick scherrer » Fri Oct 30, 2009 11:25 pm

You're welcome - good to hear it is working :)

Thanks for letting us know,

d
User avatar
dick scherrer
Global moderator
 
Posts: 6269
Joined: Sat Jun 09, 2007 8:58 am
Has thanked: 3 times
Been thanked: 93 times

Re: CEE3204S The system detected a protection exception

Postby Ajaytyagi » Thu Apr 14, 2011 8:30 pm

i am having same problem. can you please tell me how to resolve this problem.
Ajaytyagi
 
Posts: 1
Joined: Thu Apr 14, 2011 8:23 pm
Has thanked: 0 time
Been thanked: 0 time

Re: CEE3204S The system detected a protection exception

Postby prino » Thu Apr 14, 2011 8:39 pm

Ajaytyagi wrote:i am having same problem. can you please tell me how to resolve this problem.

Don't reopen a thread that has been dead for 18 months...

Recompile your program with the SUBSCRIPTRANGE prefix, i.e.

 (subrg):
 myprog: options(main) reorder;
 .
 .
 .
 end myprog;
Robert AH Prins
robert.ah.prins @ the.17+Gb.Google thingy
User avatar
prino
 
Posts: 614
Joined: Wed Mar 11, 2009 12:22 am
Location: Vilnius, Lithuania
Has thanked: 3 times
Been thanked: 27 times


Return to PL/I

 


  • Related topics
    Replies
    Views
    Last post