error u0102

Support for OS/VS COBOL, VS COBOL II, COBOL for OS/390 & VM and Enterprise COBOL for z/OS

error u0102

Postby surime72 » Thu Jan 24, 2013 9:10 pm

A user abend 0102 occurred in module DFSZSR00 CSECT DFSZSR00 at offset X'6F4'.
The abend was caused by machine instruction 0DEF (BRANCH AND SAVE) in module,
CSGCBA07 program CSGCBA07 at offset X'5948'.,

guys can you please explain uo1o2 error
Posts: 107
Joined: Sun Oct 23, 2011 1:45 pm
Has thanked: 0 time
Been thanked: 0 time

Re: error u222

Postby Akatsukami » Thu Jan 24, 2013 9:31 pm

  1. Have the title of your posts bear some slight resemblance to the content.
  2. Learn the English language and the Roman alphabet; specifically, the difference between the character "O" and the digit zero.
  3. Learn something about your job and environment; "DFS" is the significant for IMS.
  4. Read the fine manual
You've been a member of this board for over a year, and have apparently learned nothing in that time :x
"You have sat too long for any good you have been doing lately ... Depart, I say; and let us have done with you. In the name of God, go!" -- what I say to a junior programmer at least once a day
User avatar
Global moderator
Posts: 1058
Joined: Sat Oct 16, 2010 2:31 am
Location: Bloomington, IL
Has thanked: 6 times
Been thanked: 51 times

Re: error u0102

Postby c62ap90 » Fri Jan 25, 2013 2:33 am

Hmmm, something about a restart ? Not sure. ... F0102.html
Posts: 125
Joined: Thu Oct 11, 2012 10:24 pm
Has thanked: 1 time
Been thanked: 7 times

Re: error u0102

Postby Ed Goodman » Fri Jan 25, 2013 9:51 pm

The "DFS" tells me it's an IMS program. The U0102 tells me that IMS program is trying to do a restart, but is having troulbe matching up the log file with the expected format.

So... you are performing an XRST call, and the parm to that call is not blank, so the IMS system goes out to the IMSLOGR DD statement and starts trying to find the checkpoint given by the parm.

When I've done this, it's usually the wrong generation of the log file. I run a job and the IEFRDER (output log) gets cataloged as generation 1. It blows up and needs to restart, but I don't notice that. I run it a second time and it blows up with a U0047, U0041 or something that tells me I need to fix the databases, but it catalogs a new output log, generation 2, that is almost empty. I un-DUMMY the IMSLOGR DD, and put in the last checkpoint from the first run into the parm and resubmit.

The IMSLOGR is relative generation 0, which is now generation 2, but the REAL log is generation 1. So I get a U0102. I have to change the IMSLOGR generation to now be -2 ('cuz I just created generation 3) or hard code the generation G0001V00.

Another thing is that you change the layout of the checkpoint area between the abend and the restart. Don't do that, it give U0102.

Also, a bad set up of the XRST parms can put something besides spaces in the parm, and the program will try to restart on the first run, and since the IMSLOGR is usually DUMMY'd, it will get a U0102.

Don't delete generations of the log files from the top in order to get them to line up. The problem is that IMS keeps track of which generation was used and if you create a duplicate log name, restarts will start failing.
Ed Goodman
Posts: 341
Joined: Thu Feb 24, 2011 12:05 am
Has thanked: 3 times
Been thanked: 17 times

Return to IBM Cobol


  • Related topics
    Last post