HSM s not working properly



IBM OS/370, MVS, OS/390, Linux, TPF, VM/CMS, VM/ESA, VSE/ESA, z/VM, z/VSE, z/OS, z/OS.e etc...

HSM s not working properly

Postby Antonyraj85 » Wed Sep 21, 2011 5:09 pm

Hi All,

We have enabled and scheduled HSM automatic backup for some of the datasets with specific management class. So it doing migration without any problem. Since it is small system, it is migrated 1 to 100 data sets(About 15 tracks each) per day. After migration, the same tapes has not been used in the next day. DFHSM always request new scratch tapes for every auto migration call. So it extremely increases the tape counts within a month.

Any help or Suggestion !!!!!!

Antony
Antonyraj85
 
Posts: 79
Joined: Mon Jun 14, 2010 9:51 am
Has thanked: 0 time
Been thanked: 0 time

Re: HSM s not working properly

Postby enrico-sorichetti » Wed Sep 21, 2011 5:48 pm

HSM s not working properly

yes it is, it works according to Your parametrization
not an hsm fault if You/Your support are incompetent==> do not know how to setup properly HSM
You might not ( be incompetent ) ...
blaming HSM for a poor parametrization shows certainly a poor approach to problem solving
and for sure a poor approach in asking help for Your issues

steps to take...
1st) get proper training in hsm, in reading and researching the manuals, lurking thru the ARC members in SYS1.SAMPLIB
2nd) check the <HSM> installation manuals on how to configure ARC... and friends for the proprer tape handling
3rd) last resort
SETSYS PARTIALTAPE(MARKFULL)
Migration and backup tapes that are partially filled during tape output processing are marked full. This enables a scratch tape to be selected the next time the same function begins. Marking tapes full enables full exploitation of the cartridge loaders because the cartridge loaders can be filled with scratch tapes between tape processing windows. MARKFULL should be used in a virtual tape environment to improve performance and improve backstore tape utilization.
When the total tape-media use and reducing recycle overhead are more important than cartridge-loader exploitation, PARTIALTAPE(REUSE) can be specified. In a REUSE environment, tapes are fully utilized and the amount of recycle processing is reduced. For more information about the PARTIALTAPE parameter, see Selecting a Scratch Pool Environment.
Because a request to recall a data set can “take away” a migration volume that is currently associated with a migration task, such a partial migration tape is created as if you had specified PARTIALTAPE(REUSE).


and my usual suggestion when I see such poorly worded questions
to make the most out of the questions You ask and to forecast the comments You might receive
it would be wise for You to read and meditate on
how to ask questions the smart way
here http://catb.org/~esr/faqs/smart-questions.html
or .. for a more PC language
here http://support.microsoft.com/kb/555375
cheers
enrico
When I tell somebody to RTFM or STFW I usually have the page open in another tab/window of my browser,
so that I am sure that the information requested can be reached with a very small effort
enrico-sorichetti
Global moderator
 
Posts: 2957
Joined: Fri Apr 18, 2008 11:25 pm
Has thanked: 0 time
Been thanked: 159 times

Re: HSM s not working properly

Postby enrico-sorichetti » Wed Sep 21, 2011 5:59 pm

follow on
here is the relevant snippet from SYS1.SAMPLIB

 181632  SETSYS                      /* REUSE TAPES THAT ARE PARTIALLY    */ - 
 181984    PARTIALTAPE(              /* FULL. DO NOT MARK THEM AS FULL.   */ - 
 182336     BACKUP(REUSE) -                                                     
 182688     MIGRATION(REUSE))                                                   


do You realize that my reply and it's tone would have been completely different
if You had simply asked how to do it, without the <dummy> consideration about HSM not working properly ???
cheers
enrico
When I tell somebody to RTFM or STFW I usually have the page open in another tab/window of my browser,
so that I am sure that the information requested can be reached with a very small effort
enrico-sorichetti
Global moderator
 
Posts: 2957
Joined: Fri Apr 18, 2008 11:25 pm
Has thanked: 0 time
Been thanked: 159 times

Re: HSM s not working properly

Postby Antonyraj85 » Wed Sep 21, 2011 6:50 pm

Hi Enrico,
Sorry for not mentioning primary parameter. But, we already coded same parameter in ARCCMDxx and i have listed below
/*************************************************************/
/* DFHSM TAPE HANDLING SPECIFICATIONS */
/*************************************************************/
SETSYS -
DEFERMOUNT -
PARTIALTAPE(REUSE) - <------------------------
INPUTTAPEALLOCATION(NOWAIT) -
OUTPUTTAPEALLOCATION(NOWAIT) -
RECYCLETAPEALLOCATION(NOWAIT) -

But still, it is a problem.

Antony
Antonyraj85
 
Posts: 79
Joined: Mon Jun 14, 2010 9:51 am
Has thanked: 0 time
Been thanked: 0 time

Re: HSM s not working properly

Postby Antonyraj85 » Wed Sep 21, 2011 6:54 pm

Hi Enrico,

Found the following in the IBM HSM storage admin reference,

If you specify the global PARTIALTAPE(MARKFULL | REUSE) parameter, the parameter applies to both migration and backup.

Antony
Antonyraj85
 
Posts: 79
Joined: Mon Jun 14, 2010 9:51 am
Has thanked: 0 time
Been thanked: 0 time

Re: HSM s not working properly

Postby enrico-sorichetti » Wed Sep 21, 2011 6:58 pm

Antony!

why did You not tell that You had already specified that parameter to start with
it would have saved You a bit of bashing :D

are you sure that the parameter was accepted properly ,
for a certain period an improper parameter specification would cause
everything to be skipped and defaulter after the wrong one
cheers
enrico
When I tell somebody to RTFM or STFW I usually have the page open in another tab/window of my browser,
so that I am sure that the information requested can be reached with a very small effort
enrico-sorichetti
Global moderator
 
Posts: 2957
Joined: Fri Apr 18, 2008 11:25 pm
Has thanked: 0 time
Been thanked: 159 times

Re: HSM s not working properly

Postby enrico-sorichetti » Wed Sep 21, 2011 7:14 pm

most probably You already know but what does a QUERY SETSYS tell
cheers
enrico
When I tell somebody to RTFM or STFW I usually have the page open in another tab/window of my browser,
so that I am sure that the information requested can be reached with a very small effort
enrico-sorichetti
Global moderator
 
Posts: 2957
Joined: Fri Apr 18, 2008 11:25 pm
Has thanked: 0 time
Been thanked: 159 times

Re: HSM s not working properly

Postby Antonyraj85 » Wed Sep 21, 2011 7:23 pm

Hi Enrico,

Ok. No probelm. Yes, all the paramters are accepted. I could see 'SETSYS Command Completed' with no failure msg in HSM log.

Query SETSYS response is,

ARC0101I QUERY SETSYS COMMAND STARTING ON HOST=1
ARC0147I BUDENSITY=*, BUUNIT=3590-1, BU RECYCLE PERCENTAGE=020%, MOUNT WAIT
ARC0147I (CONT.) TIME=003 MINUTE(S), TAPESPANSIZE(0500)
ARC0419I SELECTVOLUME=SCRATCH, TAPEDELETION=SCRATCHTAPE, PARTIALTAPE=REUSE,


Antony
Antonyraj85
 
Posts: 79
Joined: Mon Jun 14, 2010 9:51 am
Has thanked: 0 time
Been thanked: 0 time

Re: HSM s not working properly

Postby enrico-sorichetti » Wed Sep 21, 2011 7:48 pm

there was a discussion on IBM MAIN around
http://www.mail-archive.com/ibm-main@ba ... 13477.html

what does it show in
DSBACKUP section of the display.
worth investigating the surroundings

That was rectified by the HSEND DEFINE SWITCHTAPES(DSBACKUP(AUTOBACKUPEND
PARTIALTAPE(reuse)))
cheers
enrico
When I tell somebody to RTFM or STFW I usually have the page open in another tab/window of my browser,
so that I am sure that the information requested can be reached with a very small effort
enrico-sorichetti
Global moderator
 
Posts: 2957
Joined: Fri Apr 18, 2008 11:25 pm
Has thanked: 0 time
Been thanked: 159 times

Re: HSM s not working properly

Postby mongan » Thu Sep 22, 2011 12:01 pm

You do know that you have to recycle the tapes to reduce the number used?
For example: F HSM,RECYCLE EXECUTE ALL PERCENTVALID(50)
User avatar
mongan
 
Posts: 211
Joined: Tue Jan 11, 2011 8:32 pm
Has thanked: 1 time
Been thanked: 5 times

Next

Return to Operating Systems