Transfer File from Mainframe to Local PC

TSO Programming, ISPF, SDF, SDSF and PDF, FTP, TCP/IP Concepts, SNA & SNA/IP etc...

Transfer File from Mainframe to Local PC

Postby Tushar7485 » Fri Jul 03, 2009 7:45 pm

I'm working on Mainframe through TN3270. I want to transfer a file from Mainframe to my local PC through Batch for an automation.

I went through a lot of links in the main forum but got confused regaring how to implement it. I tried using "FILEXFER" using REXX, but got the following error "Network data:'TCP/IP CONNECT RC=61".

i wanted to know how can i do a file transfer through Batch. Would it support given my Local IP address.

Posts: 2
Joined: Fri Jul 03, 2009 7:38 pm
Has thanked: 0 time
Been thanked: 0 time

Re: Transfer File from Mainframe to Local PC

Postby MrSpock » Fri Jul 03, 2009 8:18 pm

Well. we don't know your system, your desktop environments, your site standards, or anything else in order to offer much help based on what little information you've provided. All that is known at this point is that you want to transfer a file using a batch process.

Let's look at the options. You'll need to provide more details as necessary.

- FTP. File Transfer Protocol (FTP) is a client-server TCP/IP based standard. FTP requires a host server and a remote client. If you wish to initiate the transfer from the mainframe side, then the mainframe is the server and your local system is the server. That means that ir must have an FTP server running as a service. If your local machine does not have an FTP server enabled, which it most likely doesn't, then this can't work. However, most shops do have FTP-enabled servers where you can transfer your file to, and then access it by mapping that server as a drive.

- ISPF File Transfer. This is the ISPF Option 3.7. This is also a client-server application. If you can download and install the workstation client component (WSA.EXE) on your local machine, then you can use this. You can code a program that uses the ISPF Services for File Transfer and then call that program from a batch ISPF job.

- SMTP MIME. Many places will just send a file as an SMTP email MINE attachment. Certainly doable if you have the infrastructure/software to allow this.

- Other File Transfer methods. There are other products that can be used to transfer files from one system to another (Connect:Direct and XCOM are two major ones), but you of course need to have these products available and licensed for your use.
User avatar
Global moderator
Posts: 809
Joined: Wed Jun 06, 2007 9:37 pm
Location: Raleigh NC USA
Has thanked: 0 time
Been thanked: 4 times

Re: Transfer File from Mainframe to Local PC

Postby Tushar7485 » Sat Jul 04, 2009 10:11 am

Thanks for providing the options...

For FTP:- I am able to FTP the file through onilne(ISPF 3.6) & have an FTP.exe file in TN 3270 program. Does that mean i have the necessary support.

While trying through ISPF option 3.7, i dont see any option for downloading WSA.exe.

I am using TN3270 on Windows. Let me know if you need other details.

Posts: 2
Joined: Fri Jul 03, 2009 7:38 pm
Has thanked: 0 time
Been thanked: 0 time

Re: Transfer File from Mainframe to Local PC

Postby dick scherrer » Sat Jul 04, 2009 9:58 pm


The ftp program that is part of tn3270 is probably an ftp client - not what you need to send a file from the mainframe using jcl. Most organizations will not permit individual's system to be configured as an ftp server.

Try to send the file as an e-mail attachment (so long it is not larger than your e-mail system permits).
Hope this helps,
User avatar
dick scherrer
Global moderator
Posts: 6268
Joined: Sat Jun 09, 2007 8:58 am
Has thanked: 3 times
Been thanked: 93 times

Re: Transfer File from Mainframe to Local PC

Postby Steve Coalbran » Fri Jul 27, 2018 4:11 pm

I like WSA. Much quicker and faster than PCOMMs.
However, I too am suddenly experiencing problems.
I am using a remote connection to my server via: Cisco Anyconnect->Citrix XenApp->VPN->TPX->TSO! (give me my SNA back!).
The VPN part is flaky enough and often takes multiple PC Restarts to get going!
When I try to start WSA, which I have as a shortcut on my TaskBar (and has worked before many times), it starts OK and displays the WSA popup with 0 session(s) are active.
Then I go to my MS Command Prompt and enter IPCONFIG. (address changed to protect the inocent/guilty ;))


Windows IP Configuration

Ethernet adapter Local Area Connection* 11:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fc20::715b:f40:d51e:3885%16
   IPv4 Address. . . . . . . . . . . :
   Subnet Mask . . . . . . . . . . . :
   Default Gateway . . . . . . . . . :

Ethernet adapter Bluetooth Network Connection:

I Mark & Cut this to the clipboard and Paste it into my WSCON panel. Press ENTER and wait. . . . . . .
Finally... (Sorry, no GE(ON) ISPF Attributes available here)

EsssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssN s
e                   Initiate Workstation Connection                     e  
e Command ===>                                                          e  
e                                                          More:     +  e  
e /  Save values in system profile?  (/=Yes)                            e  
e                                                                       e  
e Workstation Connection                    GUI Network Protocol        e  
e 2  1. With GUI display                    1  1. TCP/IP                e  
e    2. Without GUI display                    2. APPC                  e  
e                                              3. Use ISPDTPRF file     e  
e                                                                       e  
e GUI Title                                                             e  
e                                                                       e  
e TCP/IP Address                                                        e  
e                                                            e  
e APPC Address                                                          e I
e                                                                       e 2
e ISPO921 Unable to communicate with workstation at the specified network e
e address. Probable causes: (1) the specified network address does not    e
e exist or cannot be accessed; (2) if specified, the SNA network address  e
e does not support APPC communication. Network data:'TCP/IP CONNECT RC=60 e
e '.                                                                      e

I also tried this with the "Wireless LAN adapter Wireless Network Connection" IP Address, same result. :(

Not really expecting a solution here. I will try it at work next week. That should at least omit the (flaky) VPN bit? :lol:
User avatar
Steve Coalbran
Posts: 138
Joined: Wed Apr 06, 2011 11:49 am
Location: Stockholm, Sweden
Has thanked: 13 times
Been thanked: 1 time

Return to TSO & ISPF


  • Related topics
    Last post